Ask Your Question
0

dnf using old metadata

asked 2015-04-19 02:16:02 -0500

pranavk gravatar image

I just upgraded to Fedora 22 (not released yet), which comes with dnf and have deprecated yum.

While installing any package, dnf outputs this on the console :

Using metadata from Sun Apr 19 04:27:16 2015 (8:09:10 hours old)

I also did : dnf makecache, which successfully updated the metadata but still the same message mentioned above.

I was wondering how to make dnf use the latest metadata.

Here is the full log of what I was trying to do :

Failed to synchronize cache for repo '_local' from 'file:///var/lib/dnf/plugins/local': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Using metadata from Sun Apr 19 04:27:16 2015 (8:17:19 hours old) Error: nothing provides libfreerdp-cache.so.1.2()(64bit) needed by vlc-core-2.2.0-0.2.fc21.x86_64

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-04-19 13:42:40 -0500

skytux gravatar image

Well, I'm using dnf in Fedora 21 and facing the same issue. Not sure if it is the correct way, but what I do is:

$ sudo dnf clean all

HTH,

Germán.

edit flag offensive delete link more
0

answered 2015-04-19 12:59:43 -0500

hedayat gravatar image

This seems to be related to your _local repository (created/used by "local" plugin), which seems to be not available?!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-19 02:11:35 -0500

Seen: 1,306 times

Last updated: Apr 19 '15