Ask Your Question
1

How to set Sunday as the first day of the week in Gnome Calendar, Fedora 21

asked 2015-04-19 08:34:56 -0600

Mike B. gravatar image

updated 2015-04-19 23:57:25 -0600

mether gravatar image

How to set Sunday as the first day of the week in Gnome Calendar, Fedora 21? After some searching, I found the following solution:

  1. Open as a root the /usr/share/i18n/locales/en_US.
  2. Edit the value of first_weekday to 1.
  3. Save the file, restart the system.

Where en_US is the current system localization.

I followed these steps, but no desired result received. I verified that the right localization has been edited, and the change has been really saved. Despite all this, the Gnome Calendar still displays days of the week as M T W T F S S instead of the desired S M T W T F S.

edit retag flag offensive close merge delete

Comments

By Gnome Calendar, do you mean evolution?

imoj gravatar imageimoj ( 2015-04-19 09:39:00 -0600 )edit

I mean the one, which is available on the click on the date in the top and center panel of the screen. E.g. http://i1-news.softpedia-static.com/i... , but in contrast to this screenshot, in my case the first day of the week is Monday by default. I'm using English/US localization.

Mike B. gravatar imageMike B. ( 2015-04-19 13:18:03 -0600 )edit
2

Try this please: http://askubuntu.com/questions/197613... If it works please write an answer including your steps.

imoj gravatar imageimoj ( 2015-04-19 13:34:05 -0600 )edit

I'm using Fedora 21 and the first day here is Sunday... I don't remember of having changed anything.

skytux gravatar imageskytux ( 2015-04-19 13:50:43 -0600 )edit
1

Which language & localization (regional standards) do you use?

Mike B. gravatar imageMike B. ( 2015-04-19 13:57:56 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-04-19 16:35:25 -0600

Mike B. gravatar image

updated 2015-04-19 16:36:46 -0600

The problem has been solved by the rollback of my changes and selecting the United States as a Format in Region & Language settings. Perhaps, the problem was that I changed the en_US configuration file while was using en_GB.

edit flag offensive delete link more
1

answered 2016-02-25 06:14:21 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

You missed running locale-gen (localedef in fedora)

First, double check your current system locale is 'en_US' (see variable LANG at /etc/locale.conf). Since you have already change the file en_US, that's enough. Last, run:

$ localedef -v -c -i en_US -f UTF-8 en_US.UTF-8

It works for me at Fedora23.

Source

edit flag offensive delete link more
0

answered 2015-04-21 13:39:13 -0600

Warren gravatar image

click on Time at top center of screen, open calendar, edit, preferences, under work week - choose week starts on...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-19 08:34:56 -0600

Seen: 3,268 times

Last updated: Apr 21 '15