Ask Your Question
2

How to enable touchpad tap-to-click at logon screen on Fedora 22?

asked 2015-04-23 19:06:13 -0500

diogocalgaro gravatar image

Default workstation installation: Gnome 3.16, GDM, logon screen over Wayland. After logon, the tap-to-click feature works fine.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
2

answered 2016-04-22 08:37:49 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hey, Arch user intervention!

Spent some time on Fedora until I had time to install Arch in my new machine, and I bumped across this question. After some time I figured it out, so after I wrote about it on the Arch wiki, I thought I'd share my findings here too.

So, to the point

The tap-to-click option is hidden behind the same configuration key as in the normal session, just under the gdm user.

You can either change it with a direct command or fire up the dconf editor and edit it from there.

Note: to do this under X you first have to give the gdm user access to your X session. You can do it with this simple command: sudo xhost +SI:localuser:gdm. This is not needed under Wayland.

Direct command

You will need to edit the org.gnome.desktop.peripherals.touchpad key. You can do this with this simple command:

sudo -u gdm gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true

If you want to change it back for some reason, simply replace true with false.

Using dconf-editor

This method is almost the same as the one before, with the exception that you start dconf instead of directly gsettings:

sudo -u gdm dconf-editor

 Setting tap to click as default for all X sessions

This one might come in handy too. Not many sessions provide support for configuring xf86-input-libinput, e.g. LXQt. For setting tap-to-click as default, add this to /etc/X11/xorg.conf.d/30-touchpad.conf. You will need to edit it to match your hardware:

Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
EndSection

You can also use this method to configure other options of the driver.

edit flag offensive delete link more

Comments

did not work on fedora 27

abdulkareemsn gravatar imageabdulkareemsn ( 2017-12-14 10:59:41 -0500 )edit
3

answered 2015-04-24 03:51:07 -0500

cobra gravatar image

updated 2015-04-24 03:52:00 -0500

Here's the standard way of doing it - note you need root privilege to do these changes, so use su - or sudo from the command line.

Create a new file in /etc/X11/xorg.conf.d call it something like synaptics-tap-to-click.conf

Edit the file and add something like this:

Section "InputClass"
    Identifier "tap"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "TapButton1" "1"
EndSection

Save that file out, log off (or reboot) and your touchpad should respond to taps.

edit flag offensive delete link more

Comments

It didn't work. I had something like this working on Fedora 21 a few months ago, but now with Fedora 22 it makes no difference at GDM.

diogocalgaro gravatar imagediogocalgaro ( 2015-04-24 07:12:46 -0500 )edit

There is another way I found on a Debian site, try this. Create a file called /usr/share/gdm/autostart/LoginWindow/syanptics-tap.desktop and in this file add the following:

[Desktop Entry]
Type=Application
Name=Enable Synaptics touchpad clicking
Exec=/usr/bin/synclient TapButton1=1 TapButton2=2 TapButton3=3
Terminal=false

No guarantees here, this is a solution I stumbled over that's supposed to work with gdm3. Good luck.

cobra gravatar imagecobra ( 2015-04-25 09:37:13 -0500 )edit

Thanks for the reply! This may work for synaptics driver, but Fedora 22 is using libinput driver by default in new installations. I known this command, I used to run "synclient TapButton3=3" to enable the 3-finger-click on an old Fedora 20 installation with XFCE. But now (Fedora 22 with Gnome 3.16), if I run "synclient" I get: 'Couldn't find synaptics properties. No synaptics driver loaded?'.

I found here that this is the expected behaviour of libinput, but I didn't understand how to enable it.

diogocalgaro gravatar imagediogocalgaro ( 2015-04-25 14:34:43 -0500 )edit

Indeed I don't think this will work if the login screen now uses Wayland by default. Has to be another way to enable it.

VESKE gravatar imageVESKE ( 2015-05-28 14:56:52 -0500 )edit

it didn't work on my Toshiba :(

HooRaafat gravatar imageHooRaafat ( 2015-06-20 17:40:45 -0500 )edit
3

answered 2015-04-24 08:38:13 -0500

sergiomb gravatar image

updated 2015-04-25 23:34:39 -0500

This is my configuration :

cat /etc/X11/xorg.conf.d/01-touchpad.conf

Section "InputClass"
    Identifier  "tap-by-default and other custom settings"
    MatchIsTouchpad "on"
    Option "TapButton1" "1"
    Option "TapButton2" "1"
    Option "TapButton3" "1"
    Option "VertEdgeScroll" "1"
    Option "HorizEdgeScroll" "1"
    Option "VertTwoFingerScroll" "1"
    Option "HorizTwoFingerScroll" "1"
EndSection

After configure you will need restart X .

UPDATE: you wrote: if I run "synclient" I get: 'Couldn't find synaptics properties. No synaptics driver loaded?'.
so you find the problem, your touchpad is not recognized , what you got with :

cat /var/log/Xorg.0.log| grep -i syna
edit flag offensive delete link more

Comments

It didn't work either. I have also tried something like:

Section "InputClass"
        Identifier "Enable tap-click on GDM"
        Driver "libinput"
        MatchDevicePath "/dev/input/event5"
        Option "Tapping" "1"
EndSection

No luck again. (I got the '/dev/input/event5' with the command "libinput-list-devices")

diogocalgaro gravatar imagediogocalgaro ( 2015-04-24 18:13:53 -0500 )edit
0

answered 2015-06-06 17:19:42 -0500

updated 2015-06-06 17:32:22 -0500

I don't now if it can help someone or if you've still the problem but i fixed it on fedora 22 with lxde executing this command:

synclient TapButton1=1

and you can find the list of command available to configure with

synclient -l
edit flag offensive delete link more

Comments

This worked for me.

Running stock Fedora 22 (Gnome) on a Dell XPS M1330 (yes, it's ancient).

The option to enable tap click is missing from system settings under Mouse and Trackpad, but issuing synclient TapButton1=1 worked and now I can tap click. I guess I'll have to add this to .bash_profile. Thank you!!!

poelstra gravatar imagepoelstra ( 2015-08-11 15:47:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-23 19:06:13 -0500

Seen: 10,266 times

Last updated: Apr 22 '16