English
Ask Your Question
1

DNS for OpenVPN not working

asked 2015-04-28 18:29:23 +0000

Serge gravatar image

updated 2015-04-29 02:14:45 +0000

mether gravatar image

I just migrated from Ubuntu to Fedora 21. I configured an OpenVPN client connection to a remote server using .ovpn file (import function in Network manager). Then added DNS server IP address in the IPv4 section, just the same way I did on Ubuntu. The connection works, but... domain names are not resolving. I can access any private web site by its IP address only, not by its domain name. What is the first thing I should check? What's suppossed to be the problem?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-04-29 02:29:12 +0000

You need to add a config file on /etc/NetworManager/dnsmasq.d like

configuration file my-private-net.conf

The content of the file should be something like

server=/domai-name/server-dns-ip

Hope that help.

edit flag offensive delete link more

Comments

Unfortunately, it doesn't help. I have the DNS_PROBE_FINISHED_NXDOMAIN error in my Chrome browser. Strangely the nslookup command successfully shows IP addresses of private domains, but the traceroute indicates an error.

Serge ( 2015-04-30 18:30:58 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2015-04-28 18:29:23 +0000

Seen: 1,453 times

Last updated: Apr 29 '15