Ask Your Question
8

Is something serious if 'systemctl status systemd-modules-load.service' says its 'failed'?

asked 2015-05-08 13:46:39 -0500

ddkroyal001 gravatar image

updated 2015-11-26 07:14:29 -0500

sergiomb gravatar image

After installing the updates the system displays systemd-modules-load.service is failed.

journalctl -xe output:
-- Unit UNIT has begun starting up.
May 09 00:01:02 localhost.localdomain systemd[2917]: Received SIGRTMIN+24 from PID 2971 (kill).
May 09 00:01:02 localhost.localdomain systemd[2923]: pam_unix(systemd-user:session): session closed for user root
May 09 00:01:47 localhost.localdomain org.gnome.Caribou.Daemon[1384]: ** (caribou:1718): WARNING **: AT-SPI: Error in GetItems, sender=org.freedesktop.DBus, error=The name :1.1
May 09 00:01:53 localhost.localdomain dbus[638]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service'
May 09 00:01:54 localhost.localdomain dbus[638]: [system] Successfully activated service 'net.reactivated.Fprint'
May 09 00:01:58 localhost.localdomain sudo[3163]: kabir : TTY=pts/0 ; PWD=/home/kabir ; USER=root ; COMMAND=/bin/bash
May 09 00:01:58 localhost.localdomain sudo[3163]: pam_unix(sudo-i:session): session opened for user root by kabir(uid=0)
May 09 00:04:01 localhost.localdomain systemd[1]: Configuration file /usr/lib/systemd/system/auditd.service is marked world-inaccessible. This has no effect as configuration da
May 09 00:04:01 localhost.localdomain systemd[1]: Configuration file /usr/lib/systemd/system/wpa_supplicant.service is marked executable. Please remove executable permission bi
May 09 00:04:15 localhost.localdomain systemd[1]: Configuration file /usr/lib/systemd/system/auditd.service is marked world-inaccessible. This has no effect as configuration da
May 09 00:04:15 localhost.localdomain systemd[1]: Configuration file /usr/lib/systemd/system/wpa_supplicant.service is marked executable. Please remove executable permission bi
May 09 00:04:37 localhost.localdomain systemd-modules-load[3271]: Failed to find module 'vboxdrv'
May 09 00:04:37 localhost.localdomain systemd-modules-load[3271]: Failed to find module 'vboxnetflt'
May 09 00:04:37 localhost.localdomain systemd-modules-load[3271]: Failed to find module 'vboxnetadp'
May 09 00:04:37 localhost.localdomain systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=1/FAILURE
May 09 00:04:37 localhost.localdomain systemd[1]: Failed to start Load Kernel Modules.
-- Subject: Unit systemd-modules-load.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit systemd-modules-load.service has failed.
-- 
-- The result is failed.
May 09 00:04:37 localhost.localdomain systemd[1]: Unit systemd-modules-load.service entered failed state.
May 09 00:04:37 localhost.localdomain systemd[1]: systemd-modules-load.service failed.
May 09 00:06:06 localhost.localdomain chronyd[634]: Selected source 120.88.46.10


systemctl status systemd-modules-load.service output:

[root@localhost ~]# systemctl status systemd-modules-load.service
โ— systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Sat 2015-05-09 00:04:37 IST; 7min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 3271 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 3271 (code=exited, status=1/FAILURE)

May 09 00:04:37 localhost.localdomain systemd-modules-load[3271]: Failed to find module 'vboxdrv'
May 09 00:04:37 localhost.localdomain systemd-modules-load[3271]: Failed to find ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2015-05-28 07:35:29 -0500

sergiomb gravatar image

updated 2015-05-28 07:39:26 -0500

Hi, when system start booting appears this kind of message but it is harmless, when in happens in middle of booting. It is showing that you haven't installed kmods of VirtualBox for kernel that is booting , this can happen a lot (unfortunately) , and may happen for lot of reasons, we are trying improve that .... Anyway, you always may try :

yum install kmod-VirtualBox-$(uname -r) kmod-VirtualBox

if kmod-VirtualBox-$(uname -r) was not found , please check if kmods still in rpmfusion-free-updates-testing repo with:

yum install kmod-VirtualBox-$(uname -r) kmod-VirtualBox  --enablerepo=rpmfusion-free-updates-testing

After install kmod-VirtualBox-$(uname -r) , you need rerun (to load modules) :

systemctl restart systemd-modules-load.service

Without kmods installed, you can't run virtual machines of VirtualBox.

Thanks

edit flag offensive delete link more

Comments

[kabir@localhost ~]$ systemctl status systemd-modules-load.service โ— systemd-modules-load.service - Load Kernel Modules Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static) Active: active (exited) since Sun 2015-05-31 03:36:55 IST; 5min ago Docs: man:systemd-modules-load.service(8) man:modules-load.d(5) Process: 367 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS) Main PID: 367 (code=exited, status=0/SUCCESS) CGroup: /system.slice/systemd-modules-load.service

May 31 03:36:55 localhost.localdomain systemd

ddkroyal001 gravatar imageddkroyal001 ( 2015-05-30 17:17:15 -0500 )edit

ok it is active and running.

ddkroyal001 gravatar imageddkroyal001 ( 2015-05-30 17:18:12 -0500 )edit

Thanak You

ddkroyal001 gravatar imageddkroyal001 ( 2015-05-30 17:20:17 -0500 )edit

Thanks @sergibomb for your answer. Why is it that I get that error message during boot even though I don't have VirtualBox installed?

theonlyandy gravatar imagetheonlyandy ( 2017-03-19 04:47:04 -0500 )edit

please run "systemctl status systemd-modules-load.service" and try identify the problem , I read somewhere the problem is fixed in F25 ...

sergiomb gravatar imagesergiomb ( 2017-03-19 21:21:07 -0500 )edit
4

answered 2015-11-26 05:46:08 -0500

basic6 gravatar image

updated 2015-12-16 05:48:49 -0500

The approach described in the accepted answer (using precompiled kmod modules) works perfectly most of the time, but sometimes the required kmod-VirtualBox package (for your kernel) is not in the repository yet, so you would not be able to use VirtualBox until it is.

There is an alternative way, using akmods. This means that the modules are built on your system, so it should always work.

Install the akmod-VirtualBox package and the kernel headers:

# dnf install akmod-VirtualBox kernel-devel

You may uninstall the kmod packages because you don't need them anymore (and it might not work with them installed):

# dnf remove kmod-VirtualBox-*

Either reboot or start the build process manually:

# akmods

You may have to unload the old kernel modules (those could still be loaded after a VirtualBox upgrade):

# rmmod vboxnetadp vboxnetflt vboxdrv

If everything is working now, restarting the modules service should not print any error message:

# systemctl restart systemd-modules-load

VirtualBox should then be able to start vms.

After a kernel update, the system should automatically take care of rebuilding the required VirtualBox modules.

edit flag offensive delete link more
2

answered 2015-05-08 14:44:54 -0500

There isn't a Virtualbox module available for the kernel you booted. Wait for an update, or try GNOME Boxes or virt-manager instead and enjoy playing with VMs without these issues

edit flag offensive delete link more

Comments

It seems I have the same trouble: systemd-modules-load.service: Failed with result 'exit-code' from my dmesg. but the point is that I do not wish to have/use vm ... boxes ... How can I clean the situation?

aurelien gravatar imageaurelien ( 2016-03-17 11:29:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-08 13:46:39 -0500

Seen: 25,471 times

Last updated: Dec 16 '15