Ask Your Question
1

Fedora22 Dnf update/install slow

asked 2015-05-27 17:17:09 -0500

arcsorder gravatar image

updated 2015-05-28 08:37:25 -0500

mether gravatar image

What's happening with the mirrors?

Am I missing something? took about 20 minutes to update one repo

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2015-09-10 17:24:24 -0500

Sidaphextwin gravatar image

Hi, this is the solution:

Edit /etc/dnf/dnf.conf and add:

fastestmirror=true

edit flag offensive delete link more

Comments

I did this (Fedora 23) and now it apparently checks the mirrors:

determining the fastest mirror (3 hosts).. done.

But when it tries to update from Fedora 23 - x86_64 repo it keeps very sluggish

damonh gravatar imagedamonh ( 2016-01-24 16:56:01 -0500 )edit

Worked like a charm for me. On Fedora 24.

uncoolshogun gravatar imageuncoolshogun ( 2016-12-07 13:14:31 -0500 )edit

yeah this doesn't work for me either. i'm trying to use fedora on a digital ocean droplet but it's basically unusable. dnf is broken out of the box. going to have to wipe it and use a different distro.

donbright gravatar imagedonbright ( 2017-01-25 22:10:29 -0500 )edit
0

answered 2015-05-27 20:36:30 -0500

florian gravatar image

That could happen at times of mass upgrades ... are you sure that you are using the best mirrors?

Try a sudo dnf clean all, followed by a sudo dnf check-update. Maybe you have faster mirrors somewhere close. 20 minutes seems to be too long for repo information (~20-50 MB).

edit flag offensive delete link more

Comments

It depends on Internet connection too, so even at the best speed (50KBps) 40MB takes too long

megh gravatar imagemegh ( 2015-05-29 00:39:48 -0500 )edit

See https://bugzilla.redhat.com/show_bug.... .Somebody should work on it please.

megh gravatar imagemegh ( 2015-05-29 00:43:28 -0500 )edit
0

answered 2015-08-03 09:49:29 -0500

Yeah, I never had these problems with YUM. For some reason DNF attempts to connect at high ports (instead of FTP/HTTP) and I see a SYN_SENT which is being blocked by our network's firewall. Yum always seemed to work fast and connect only on HTTP/FTP ports.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-05-27 17:17:09 -0500

Seen: 13,408 times

Last updated: May 27 '15