Ask Your Question
0

how to set regional settings without affecting language?

asked 2015-05-28 05:17:24 -0600

On fedora 21/KDE it was easy. System settings->locale and just change country to Finland, it changes number format, currency and page size to correct form and language stays english.

With Fedora 22/KDE, System settings->regional settings->formats, there is no country setting. If i change region to Finland, it also changes language to finnish. That is something i don't want.

How to set numeric, currency and time format without affecting language?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-06-07 11:53:09 -0600

aadjan gravatar image

In System Settings - Regional Settings in Translations select your preferred language and in Formats select the regional settings for Finland and you should be done. A lot of things stay the same in KDE5. It's the subtle differences that take some figuring out.

edit flag offensive delete link more

Comments

I just tried that. After reboot, system is mostly english, calendar and firefox are still in finnish. Chrome is english.

I managed to change firefox back to english by disabling finnish language pack from firefox->extensions->languages.

airjuri gravatar imageairjuri ( 2015-06-10 04:46:48 -0600 )edit
0

answered 2015-05-29 19:51:48 -0600

This can probably be done. Take a look at the locale command: man locale

Sorry I don't have the exact procedure, but the locale command is a good starting point. The man page describes the necessary environment setup.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-28 05:17:24 -0600

Seen: 1,219 times

Last updated: May 28 '15