English
Ask Your Question
0

tuned Laptop Power Management

asked 2015-05-29 01:04:52 +0000

standard7452 gravatar image

updated 2015-05-29 05:15:49 +0000

Good Evening,

I have installed Fedora 22 on a laptop with the following specs (as registered by the Details section of Settings:

Memory: 3.7 GiB Processor: Intel® Pentium(R) CPU P6100 @ 2.00GHz × 2 OS Type: 64-bit Graphics: Intel® Ironlake Mobile GNOME: Version 3.16.2 Disk: 54.8 GB

I want to increase the battery-life of my laptop. So I searched and found the following document:

http://docs.fedoraproject.org/en-US/Fedora/19/pdf/Power_Management_Guide/Fedora-19-Power_Management_Guide-en-US.pdf

This was the most recent one I could easily find, and it was for Fedora 19. Because I could not find a more recent version to try, I attempted to set up tuned.

So I:

[wbest@new-host-3 ~]$ su -
Password: 
[root@new-host-3 ~]# yum install tuned
Yum command has been deprecated, redirecting to '/usr/bin/dnf install tuned'.
See 'man dnf' and 'man yum2dnf' for more information.
To transfer transaction metadata from yum to DNF, run:
'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'

Last metadata expiration check performed 1:40:29 ago on Thu May 28 19:15:43 2015.
Package tuned-2.4.1-5.fc22.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@new-host-3 ~]# ^C
[root@new-host-3 ~]#

So then, I tried the steps to start and enable tuned located in the document cited above. Here is the output:

[root@new-host-3 ~]# systemctl start tuned
[root@new-host-3 ~]# systemctl enable
Too few arguments.
[root@new-host-3 ~]#

I get too few arguments. What am I doing wrong.

Thanks! Will

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2015-05-29 05:15:08 +0000

You didn't put what you wanted to enable in the command:

systemctl enable tuned

edit flag offensive delete link more

Comments

Thank you for answering so quickly! The directions in the PDF I linked just reads:

"To enable tuned to start every time the machine boots, type the following command: systemctl tuned enable"

Is there something else that has to come after that?

Thanks in advance,

~Will

standard7452 ( 2015-05-29 12:05:35 +0000 )edit

Hrm... that's the wrong syntax. The guide should be fixed. The rest of the guide talks about tuned profiles and such, they should still apply.

randomuser ( 2015-05-29 13:54:13 +0000 )edit

So is there another way to have tuned auto-start when the computer turns on?

standard7452 ( 2015-05-29 14:50:18 +0000 )edit

No, the command in my answer is the way to enable it to start on boot.

randomuser ( 2015-05-29 16:33:55 +0000 )edit

Oh boy am I stupid! I see, the answer now! Thanks for helping this dummy!

standard7452 ( 2015-05-29 22:32:54 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2015-05-29 01:04:52 +0000

Seen: 237 times

Last updated: May 29 '15