English
Ask Your Question
3

Why is Num Lock ALWAYS an issue with EACH Release?!? It's 2015!!!

asked 2015-05-31 01:10:53 +0000

ConWrite gravatar image

updated 2015-06-05 23:39:58 +0000

mether gravatar image

I apologize in advance for my mock irritability, but I've dumped a ton of time into this over the years.


The recent F22 is different somehow than previous Fs. Everything I've done in the past (F21 and before) no longer works.

Yes, numlockx is installed

Yes, I have tried multiple scripts

No, there is nothing in the BIOS for numlock


The Number Keys are Labeled as Numbers, why isn't what they are labeled as the Default!?

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora! Alas, I can't answer your question directly, because I prefer numlock off for various reasons. However, a little research suggests that you need to add it to startx, before the exec statement. How have you been invoking it? (Please respond in a comment, instead of using your only answer for this question.)

sideburns ( 2015-05-31 02:26:02 +0000 )edit

What happens when you run /usr/bin/numlockx directly? Does journalctl -b show the attempt to execute /etc/X11/xinit/xinitrc.d/numlockx.sh ?

randomuser ( 2015-05-31 03:19:01 +0000 )edit

Thanks for the responses and the welcome. The strange thing is, if the numlock light is to be believed, the computer starts with it on and stays on almost right up to when the logon screen appears. However, the numlock worked just fine in F21 without the light staying on. Anyway, the numlockx executable is in bin with permission set for read and write for all, although I've never had to do that before -- trying just about anything. I've tried /usr/bin/numlockx on in a few places in /etc/X11/xinit/xinitrc even though the included instructions say place "At the beginning of the file..."

ConWrite ( 2015-05-31 20:42:41 +0000 )edit

I've also done this

At the end of the file you will find a line like

exit 0

Above this line add the following code

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi

Through Tweak Tool (using GNOME 3 BTW) I have numlockx included in startup applications - which seems to work, but only after I've logged in and usually already have manually turned it on. I read somewhere about ctrl+shift+numlock and I've tried that at various times and it does nothing for me. Unfortunately, journalctl -b does not show the attempt, so something is missing apparently.

ConWrite ( 2015-05-31 20:45:08 +0000 )edit

numlockx and numlockx.sh shell scripts are in /etc/X11/xinit/xinitrc.d. I've tried one or two other things based on searches but those escape me now but nothing done wasn't reversible. I think that's everything, brain on lock. Thanks for your time.

ConWrite ( 2015-05-31 20:46:44 +0000 )edit

5 answers

Sort by ยป oldest newest most voted
2

answered 2015-06-12 16:29:02 +0000

damus gravatar image

On Fedora 22, GDM runs on top of Wayland by default instead of X. And in that case, numlockx will not work. So, for numlockx to work on login screen, you have to force GDM to use Xorg. Edit this file /etc/gdm/custom.conf and uncomment the line WaylandEnable=false. And then activate numlockx on login screen by placing

if [ -x /usr/bin/numlockx ]; then
  /usr/bin/numlockx on
fi

at the end of /etc/gdm/Init/Default (after the last fi but before exit 0). This worked for me on Fedora 22, using Gnome 3.16.

edit flag offensive delete link more
1

answered 2016-09-26 22:25:33 +0000

ConWrite gravatar image

updated 2016-09-26 22:33:53 +0000

Alright, Distro Hopping has brought me back here to try again and I can Finally report success. A combination of below did the trick for me.

Edit this file /etc/gdm/custom.conf and uncomment the line WaylandEnable=false. And then activate numlockx on login screen by placing

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on fi

at the end of /etc/gdm/Init/Default

(From Damus' comment elsewhere on This page)

AND

Typing >> Layout of numeric keypad >> Legacy

(From https://ask.fedoraproject.org/en/ques... )

For me it has to be Both, as I tried each individually with unsatisfactory results.

Much Thanks to damus and Frttls and everyone else that offered suggestions that might very well work for others.

edit flag offensive delete link more
1

answered 2015-06-05 19:23:29 +0000

sideburns gravatar image

I think I know what's needed: create a shell script that simply runs numlockx, make it executable and run it from /etc/rc.d/rc.local so that it's called at the end of the boot process, but before you log in. My understanding is that systemd will activate the proper service to run that file automatically, as soon as it recognizes that it's there.

edit flag offensive delete link more

Comments

I know it wasn't listed, but this was one of the many other things I tried. BUT I tried it again and it still didn't work for me. I very much appreciate your assistance, but I'm not wasting anymore time on this. I've used Fedora on the computer I'm typing on now since F17, however, this and the fact that F22 freezes on me regularly along with a couple of other issues... well, obviously to me, it's time to move on to a different distro. Thanks again for your help.

ConWrite ( 2015-06-08 20:54:51 +0000 )edit

One, last thing before you do: check to see if rc-local.service is active by running this: systemctl status rc-local.service I know that it's supposed to be active if /etc/rc.d/rc.local exists and is executable, but it can't hurt to check.

sideburns ( 2015-06-08 21:43:13 +0000 )edit

It's a tad disheartening that a motivating suggestion is presented after essentially giving up. I still suspect what you mentioned is related to the issue though. There wasn't a rc.local file by default and when I created one, I did so with a grasping at straws mindset after trying other approaches. It seems silly to me now that I didn't do a status check - I guess thinking it would work or it wouldn't. I assure you, I started this believing getting numlock setup would be no big deal and even when that turned out not to be true, for me at least, positivity endured through much of the effort.

ConWrite ( 2015-06-09 19:16:41 +0000 )edit

Well, more time has been used & while I feel I have learned a fair amount, which has value of course, a fix eludes me. When I check the status after various iterations, the best I get is

Loaded: loaded (/usr/lib/systemd/system/rc-local.service; enabled; vendor preset: disabled)
Active: active (exited) since Tue 2015-06-09 13:57:48 EDT; 25min ago
Main PID: 920 (code=exited, status=0/SUCCESS)
..rc.local[920]: Error opening display!

I can't remember all that I've tried now & the reward just isn't enough to justify more time. Yours & randomuser's help has been greatly appreciated

ConWrite ( 2015-06-09 19:18:42 +0000 )edit
0

answered 2017-07-21 08:49:39 +0000

tolisp gravatar image

Confirmed that

Universal Access > Pointing & Clicking > Mouse Keys Off

is the fix to the problem, had the same issue after upgrading to F26. Upon disabling the problem is fixed.

edit flag offensive delete link more
0

answered 2016-04-11 13:09:52 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I solved my NumLock not working / Number Keypad not working issue on my laptop running Fedora 21 by turning off Mouse Keys, found here - All Settings > System > Universal Access > Pointing & Clicking > Mouse Keys Off

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2015-05-31 01:10:53 +0000

Seen: 3,327 times

Last updated: Jul 21