Ask Your Question

How do I install the latest version of GNU Octave on Fedora 22?

asked 2015-06-05 09:22:09 +0000

BH2017 gravatar image

updated 2016-02-14 01:04:33 +0000

mether gravatar image

I would like to install GNU Octave 4.0.0 (the latest version, released in 29 May 2015, not available in the repository. The latest version available in the F22 repo is 3.8.2) on F22. I have downloaded the tarball, transferred the source directory into /opt. I then ran:

cd /opt/octave

to receive the error:

configure: error: A BLAS library was detected but found incompatible with your Fortran 77 compiler settings.

I thought I might be able to ignore this and just run make still in root but alas, no as no make targets were found in the /opt/octave directory. If you're wondering if I'm missing dependencies I have run yum builddep octave before running these lines so I'd have the requirements for the previous version of octave that's available in the repo (3.8.2), why I even re-ran this builddep line after my failed installation attempt and re-ran the ./configure line.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-06-05 10:42:49 +0000

geforce gravatar image

updated 2015-06-05 10:58:31 +0000

Ok try rebuilding this srpm


dnf groups install "Development Tools"
dnf install rpmdevtools
cd ~
rpmbuild --rebuild https://dl.dropboxusercontent.com/u/6907158/octave-4.0.0-1.fc23.src.rpm
edit flag offensive delete link more


Sorry I'm on 32 bit F22, not 64 bit.

BH2017 ( 2015-06-05 10:44:29 +0000 )edit

Sorry uploaded wrong file, I have uploaded the srpm and linked it to my previous post

geforce ( 2015-06-05 10:48:59 +0000 )edit

How do I build a srpm? Forgive my ignorance, I've only been using Fedora for a few days.

BH2017 ( 2015-06-05 10:53:05 +0000 )edit

steps to build added to my previous post

geforce ( 2015-06-05 10:59:16 +0000 )edit

Thanks it worked. After I created the RPM I installed it via dnf install.

BH2017 ( 2015-06-05 12:11:05 +0000 )edit

answered 2015-06-05 10:09:07 +0000

geforce gravatar image

Try this (change lib64 to suit).

./configure --with-blas="-L/usr/lib64/atlas -ltatlas"
edit flag offensive delete link more


This gives the same error I'm afraid and still no make targets built.

BH2017 ( 2015-06-05 10:27:29 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2015-06-05 09:22:09 +0000

Seen: 3,068 times

Last updated: Jun 05 '15