English
Ask Your Question
0

How to resolve the issue regarding to gnome-shell in Fedora22?

asked 2015-06-07 13:36:50 +0000

Gaurav Dighe gravatar image

I have Fedora22 installed. I have installed NVIDIA-340 driver from rpmfusion. After that, I am facing issue that Gnome-Shell breaks. I have reported this bug.

So what to do in this case.

I do lot of gaming on steam and require the high performance of graphics.

Please revert

edit retag flag offensive close merge delete

Comments

Try disable wayland... read here: https://ask.fedoraproject.org/en/ques...

davidva ( 2015-06-10 16:30:50 +0000 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-07 15:31:06 +0000

geforce gravatar image

Either remove nvidia

dnf remove *nvidia*

Or use a proper DE that actually works properly with nvidia

dnf install @cinnamon
systemctl disable gdm.service
systemctl enable lightdm.service
edit flag offensive delete link more

Comments

I followed the steps above and came up with a desktop that is extremely different from Gnome, where do I find the instruction manual for it?

wafra ( 2015-06-08 04:54:04 +0000 )edit

Try here (ignore the package management stuff as cinnamon uses yumex or gnome-software for this).

http://www.linuxmint.com/documentatio...

cinnamon was forked from gnome, the main difference is it's layout and the settings tool (cinnamon-settings).

geforce ( 2015-06-10 06:53:36 +0000 )edit
0

answered 2015-06-10 04:43:26 +0000

Gaurav Dighe gravatar image

I tried akmod-nvidia-340 from rpmfusion. But gnome-shell breaks.

edit flag offensive delete link more
0

answered 2015-06-07 15:50:48 +0000

cgonz31 gravatar image

If you are running kernel version 4.0.4-302.fc22.x86_64 or newer, then the corresponding kmod-nvidia packages are still not available. According to my dnf search and the online RepoView, the only kmod-nvidia package available is kmod-nvidia-4.0.4-301.fc22.x86_64 (plus the 32-bit and 32-bit PAE versions).

I have a machine with the kmod-nvidia-340 driver from RPM Fusion and I can only get to the desktop on kernel version 4.0.4-301.fc22.x86_64.

Until the drivers for newer kernels are published, then we have no choice but use the 4.0.4-301.fc22.x86_64 kernel.

edit flag offensive delete link more

Comments

You will have a long wait for the kmods as they haven't been built yet and are a low priority till rpmfusion gets it's new build server (f22 only is affected). As for waiting, thats a load of bull!, just use akmod-nvidia-340 instead

geforce ( 2015-06-07 16:49:33 +0000 )edit

Before the FedUp to F22, I could only get my desktop to work with the kmod-nvidia packages. The akmod-nvidia package did not work for me.

Though, it's worth a shot trying again on F22 to see with the akmod-nvidia will work for me.

cgonz31 ( 2015-06-08 00:34:04 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
3 followers

Stats

Asked: 2015-06-07 13:36:50 +0000

Seen: 700 times

Last updated: Jun 10 '15