Ask Your Question
3

yum-plugin-fastestmirror Fedora 22

asked 2015-06-11 18:55:32 -0500

raed gravatar image

hello guys

i want to update fedora 22 but the speed of update is very slow even when i have a good internet speed 20mb/s, but now i have 10kb/s this will take so long time so previously in fedora i was using "yum-plugin-fastestmirror" and it increse my internet speed when update or install packages, but now i can't install it in fedora 22 after i logged in as root.

[raed@localhost ~]$ su - Password: [root@localhost ~]# yum install yum-plugin-fastestmirror Yum command has been deprecated, redirecting to '/usr/bin/dnf install yum-plugin-fastestmirror'. See 'man dnf' and 'man yum2dnf' for more information. To transfer transaction metadata from yum to DNF, run: 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'

Last metadata expiration check performed 0:00:50 ago on Fri Jun 12 02:41:12 2015.

Dependencies resolved.

Package Arch Version Repository Size

Installing: yum-plugin-fastestmirror noarch 1.1.31-505.fc22 fedora 35 k

Transaction Summary

Install 1 Package

Total download size: 35 k Installed size: 53 k Is this ok [y/N]: y Downloading Packages:

yum-plugin-fastestmirror-1.1.31-505.fc22.noarch 20 kB/s | 35 kB 00:01

Total 11 kB/s | 35 kB 00:03
Running transaction check Transaction check succeeded. Running transaction test Transaction test succeeded. Running transaction Failed to obtain the transaction lock (logged in as: root). Error: Could not run transaction.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-12 01:06:38 -0500

Two things are happening here:

  1. yum is deprecated. dnf replaced it. There is not yet a fastest mirror plugin for dnf.

  2. Something else is holding the package manager lock, probably the automatic refresh of dnf metadata. Wait it out.

edit flag offensive delete link more

Comments

dnf includes fastestmirror functionality in standard package (no plugin needed). You just need to enable it in /etc/dnf/dnf.conf by setting fastestmirror=1. It is disabled by default (man dnf.conf).

blaztinn gravatar imageblaztinn ( 2015-08-28 15:40:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-11 18:54:21 -0500

Seen: 2,709 times

Last updated: Jun 12 '15