Ask Your Question
0

Fedora 16 long boot when wireless enabled

asked 2012-12-13 14:56:27 -0500

cepido gravatar image

updated 2014-09-28 11:40:37 -0500

mether gravatar image

I have issue during booting my box. Out of the blue boot time increased. After graphic is started it takes too much time until Fedora logo is fully drawn and system boots. This is obtained from dmesg:

[   16.591562] Broadcom NetXtreme II iSCSI Driver bnx2i v2.7.2.2 (Apr 25, 2012)
[   16.591592] iscsi: registered transport (bnx2i)
[   16.599227] iscsi: registered transport (be2iscsi)
[   16.684335] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
[   16.751512] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   16.755068] tg3 0000:18:00.0: irq 47 for MSI/MSI-X
[   16.786860] IPv6: ADDRCONF(NETDEV_UP): p3p1: link is not ready
[   18.375736] tg3 0000:18:00.0: p3p1: Link is up at 100 Mbps, full duplex
[   18.375741] tg3 0000:18:00.0: p3p1: Flow control is on for TX and on for RX
[   18.375789] IPv6: ADDRCONF(NETDEV_CHANGE): p3p1: link becomes ready
[   42.497642] wlan0: authenticate with 00:11:2f:a2:99:1c
[   42.499067] wlan0: send auth to 00:11:2f:a2:99:1c (try 1/3)
[   42.500758] wlan0: authenticated
[   42.500854] iwl3945 0000:10:00.0: wlan0: disabling HT as WMM/QoS is not supported
[   42.502012] wlan0: associate with 00:11:2f:a2:99:1c (try 1/3)
[   42.504173] wlan0: RX AssocResp from 00:11:2f:a2:99:1c (capab=0x411 status=0 aid=1)
[   42.505421] wlan0: associated
[   43.941683] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   43.941688] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   43.941694] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   43.941716] cfg80211: Calling CRDA for country: SK
[   43.959005] cfg80211: Regulatory domain changed to country: SK
[   43.959005] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   43.959005] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   43.959005] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   43.959005] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   43.959005] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[   98.779852] wlan0: authenticate with 00:11:2f:a2:99:1c
[   98.782289] wlan0: send auth to 00:11:2f:a2:99:1c (try 1/3)
[   98.784168] wlan0: authenticated
[   98.784401] iwl3945 0000:10:00.0: wlan0: disabling HT as WMM/QoS is not supported
[   98.786040] wlan0: associate with 00:11:2f:a2:99:1c (try 1/3)

The last message that I have seen during boot when I press ESC was "starting job spooling tools" and at this point the system was hanged.

My box:

  • Linux HP-PC 3.6.7-4.fc16.x8664 #1 SMP Tue Nov 20 20:33:31 UTC 2012 x8664 x8664 x8664 GNU/Linux
  • Compaq 6710b

Thank you

Edited 12/12/15 For clarifying: System not hangs, just it takes some time until it boots. This happens when I have wireless interface enabled (with wireless button). During last boot ... (more)

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-14 08:20:49 -0500

ThomasMcA gravatar image

See this for additional ideas. Although not wireless-specific, that link could still help minimize your startup times.

Also, see this. Do you have both NetworkManager.service and network.service active? If so, they are probably conflicting with each other, causing the delay.

edit flag offensive delete link more
0

answered 2012-12-14 21:05:09 -0500

ThomasMcA gravatar image

Is it hung, or does it just take a long time to boot?

Please search the Internet and/or this forum before posting. I answered a similar question on this forum only 12 days ago:

https://ask.fedoraproject.org/question/3071/slowly-boot-with-fedora-17

edit flag offensive delete link more
0

answered 2012-12-18 13:31:36 -0500

ThomasMcA gravatar image

It looks like it is getting hung up when it tries to connect to your wireless. Here are some options:

  1. Google this error: wlan0: disabling HT as WMM/QoS is not supported
  2. Disable IPv6 in your wireless router - home wireless networks rarely need IPv6
  3. Try booting with wireless turned off - does it boot faster?
edit flag offensive delete link more
0

answered 2013-01-02 11:41:24 -0500

ThomasMcA gravatar image

Disable IPv6 in Fedora by adding the following lines to the end of /etc/sysctl.conf

# Disable ipv6
net.ipv6.conf.all.disable_ipv6=1
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-13 14:56:27 -0500

Seen: 1,186 times

Last updated: Jan 14 '13