English
Ask Your Question
0

Unable to use HP network scanner

asked 2015-06-17 15:29:46 +0000

luya gravatar image

updated 2015-06-26 03:52:17 +0000

mether gravatar image

HP all-in-one printer Photosmart eStation was correctly detected in the network and can be used for print. Unfortunately, any scanner application does not. Is there a solution to fix that problem using Gnome settings?

edit retag flag offensive close merge delete

Comments

Does that scanner has a web interface, my Photosmart has one that allow me to scan, it is not the best solution but works specially since I don't want to connect to it with the USB cable

aeperezt ( 2015-06-17 15:33:29 +0000 )edit

Yes it does have a web interface. Although I know the ip, I tried to figured a permanent solution for that problem.

luya ( 2015-06-17 15:41:53 +0000 )edit

if you have a linux machine connected to the scanner try sane and dnf install sane-frontends xsane this has a good documentation on it https://wiki.archlinux.org/index.php/... but not figured out how to work over the network

aeperezt ( 2015-06-17 15:57:39 +0000 )edit

I posted the suggestion. BRPocock's solution is also good due to reason below.

luya ( 2015-06-19 05:56:38 +0000 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2015-06-17 16:02:03 +0000

BRPocock gravatar image

Most HP all-in-one scanners are supported by package hplip-gui (pkcon install hplip-gui) — which installs the “HP Device Manager” application. This could/should enable configuring your scanner. Once it's enabled, a program like simple-scan or xsane should be able to draw from it.

edit flag offensive delete link more

Comments

That step can be optional when running from the terminal using hp-setup command

luya ( 2015-06-17 16:57:27 +0000 )edit
0

answered 2015-06-17 16:51:53 +0000

luya gravatar image

I figured out the problem. The correct device location should start with hp:/net rather than dnssd. It is like hp:/net/devicename/zc=hostname where devicename is self-explanatory and the hostname is the host as listed from the web interface. The full name can be detected using hp-setup hostname. For example, my device listed as hp:/net/Photosmart_eStn_C510_series/zc=HPFFCB9

If you are using ip address instead, replace zc=hostname by ip="ip address".

I just remember I filed that report a while ago and had a solution link text. The bug is from upstream hplip. Anyone having a network HP all-in-one printer should try that workaround and make sure to restart cups (sudo systemctl restart cups) or simply reboot. Also read the rationale behind the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2015-06-17 15:29:46 +0000

Seen: 2,896 times

Last updated: Jun 17 '15