English
Ask Your Question
1

Unable to connect to wireless access point with WPA2

asked 2011-12-16 15:16:18 +0000

Stephen gravatar image

updated 2011-12-18 16:45:29 +0000

My wireless router is setup to use WPA2-Personal encryption with AES. When I startup and click on my ESSID it naturally asks me for my passphrase. Fine and dandy but then it hangs for a bit before asking me for the passphrase again. Ok. So logging into the router with a wired connection confirms that I know the correct passphrase.

What I see is the following behavior with NetworkManager:

  1. Click on ESSID I want to connect
  2. Get GNOME3 dialog asking for passphrase
  3. Window closes
  4. Get non-GNOME3 dialog asking for passphrase
  5. Window closes
  6. NetworkManager attempts to log into another access point and repeats steps 2-5.

In previous versions I could manually setup my wireless connections. The new dialog is attempt to remove the magic from installing by hiding all the complexity from the user. What I see are its short falls are:

  1. No why to understand why a connection is failing.

  2. Why the double dialogs in two different styles asking for the passphrase. Annoying.

  3. Why is NetworkManager trying to connect to another access point after the first fails?

  4. Where are the manual setup features? (e.g Advanced user settings - yes danger will robinson)

  5. How to restart a connection?

  6. How to restart network if you had to? It use to be that you could run /etc/init.d/network restart to have that happen. In Fedora 15 I could never get the wireless to comeback after the laptop awoke from hibernation. I always had to restart the machine.

Wireless access card information

lspci | grep -i net

09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express
(rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection
(rev 02)

dmesg | grep -i iwl

iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
iwl3945: Copyright(c) 2003-2011 Intel Corporation
iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:0c:00.0: setting latency timer to 64
iwl3945 0000:0c:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
iwl3945 0000:0c:00.0: irq 47 for MSI/MSI-X
ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9

Router information

sudo iwlist scan

which I cut out the other access points:

          Cell 03 - Address: 00:1F:90:E6:41:F7
                Channel:1
                Frequency:2.412 GHz (Channel 1)
                Quality=51/70  Signal level=-59 dBm  
                Encryption key:on
                ESSID:"9west"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                          11 Mb/s; 12 Mb/s; 18 Mb/s
                Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                Mode:Master
                Extra:tsf=0000000005aeb56a
                Extra: Last beacon: 2096ms ago
                IE: Unknown: 00053977657374
                IE: Unknown: 010882848B0C12961824
                IE: Unknown: 030101
                IE: Unknown: 0706555320010B1B
                IE: Unknown: 200100
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : CCMP
                    Pairwise Ciphers (1) : CCMP
                    Authentication Suites (1) : PSK
                IE: WPA Version 1
                    Group Cipher : CCMP
                    Pairwise Ciphers (1) : CCMP
                    Authentication Suites (1) : PSK
                IE: Unknown: 2A0100
                IE: Unknown: 32043048606C
                IE: Unknown: DD180050F2020101890003A4000027A4000042435E0062322F00

Router supports WEP, WPA and WPA2

WPA2 options:

Authentication Method: Pre-shared key / 802.1x
Encryption Method: TKIP-AES / AES

WPA options:

Authentication Method: Pre-shared key / 802.1x
Encryption Method: TKIP / AES

WEP options:

WEP mode: WEP only / 802.1x
Network authentication: Open System / Shared Key / Both

Troubleshooting

  1. Tested with NetworkManager security set to:

    SSID: 9west
    Mode: Infrastructure
    BSSID: (blank)
    Device MAC address: (mac address of wlan0)
    Cloned MAC address: (blank)
    MTU: automatic
    Security: WPA & WPA2 Personal

    Result: in both WPA and WPA2 for the router was the wireless network card could not obtain an IP address.

  2. Switched to WEP 40-bit, Open System Authentication, WEP Index 1 (only key set in router)

    Result: I was asked for the key twice even though I set it using nm-connection-editor.

  3. Cannot test the no security option.

NetworkManager connection attempt

NetworkManager[1001]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[1001]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[1001]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
NetworkManager[1001]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
NetworkManager[1001]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
NetworkManager[1001]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
NetworkManager[1001]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[1001]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[1001]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[1001]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[1001]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
NetworkManager[1001]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
NetworkManager[1001]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[1001]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[1001]: <info> Activation (wlan0/wireless): connection 'Auto 9west' has security, and secrets exist.  No new secrets needed.
NetworkManager[1001]: <info> Activation (wlan0/wireless): connection 'Auto 9west' has security, and secrets exist.  No new secrets needed.
NetworkManager[1001]: <info> Config: added 'ssid' value '9west'
NetworkManager[1001]: <info> Config: added 'ssid' value '9west'
NetworkManager[1001]: <info> Config: added 'scan_ssid' value '1'
NetworkManager[1001]: <info> Config: added 'scan_ssid' value '1'
NetworkManager[1001]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
NetworkManager[1001]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
NetworkManager[1001]: <info> Config: added 'psk' value '<omitted>'
NetworkManager[1001]: <info> Config: added 'psk' value '<omitted>'
NetworkManager[1001]: <info> Config: added 'proto' value 'WPA RSN'
NetworkManager[1001]: <info> Config: added 'proto' value 'WPA RSN'
NetworkManager[1001]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[1001]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[1001]: <info> Config: set interface ap_scan to 1
NetworkManager[1001]: <info> Config: set interface ap_scan to 1
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> associating
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> associating
NetworkManager[1001]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[1001]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> associating
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> associating
NetworkManager[1001]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[1001]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> associating
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> associating
NetworkManager[1001]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[1001]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <info> (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1001]: <warn> Activation (wlan0/wireless): association took too long.
NetworkManager[1001]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
NetworkManager[1001]: <warn> Activation (wlan0/wireless): asking for new secrets
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> disconnected
NetworkManager[1001]: <warn> Activation (wlan0/wireless): association took too long.
NetworkManager[1001]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
NetworkManager[1001]: <warn> Activation (wlan0/wireless): asking for new secrets
NetworkManager[1001]: <info> (wlan0): supplicant interface state: scanning -> disconnected
NetworkManager[1001]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
NetworkManager[1001]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
NetworkManager[1001]: <warn> No agents were available for this request.
NetworkManager[1001]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
NetworkManager[1001]: <warn> Activation (wlan0) failed for access point (9west)
NetworkManager[1001]: <info> Marking connection 'Auto 9west' invalid.
NetworkManager[1001]: <warn> Activation (wlan0) failed.
NetworkManager[1001]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
NetworkManager[1001]: <info> (wlan0): deactivating device (reason 'none') [0]
NetworkManager[1001]: <warn> No agents were available for this request.
NetworkManager[1001]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
NetworkManager[1001]: <warn> Activation (wlan0) failed for access point (9west)
NetworkManager[1001]: <info> Marking connection 'Auto 9west' invalid.
NetworkManager[1001]: <warn> Activation (wlan0) failed.
NetworkManager[1001]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
NetworkManager[1001]: <info> (wlan0): deactivating device (reason 'none') [0]
edit retag flag offensive close delete

Comments

Does it work if you switch to WPA1, WEP or NO ENCRYPTION? I think it is better to answer at the bottom of your question instead of in "Answers" section.

ztank1013 ( 2011-12-16 20:40:26 +0000 )edit

I am sorry for not posting in the right section. The router I am using is a FIOS Verizon (model MI424-WR). It does not support the "NO ENCRYPTION" option. My choices are WEP, WPA and WPA2 but are reported as WEP 64-bit, WEP 802.1x and WPA2 in the router status page.

Stephen ( 2011-12-16 21:37:44 +0000 )edit

About your troubleshooting section were you asked for password twice for both WPA[12] and WEP? Sorry I do not understand if you typed your password in the configuration (nm-connection-editor) or just when prompted in the double window.

ztank1013 ( 2011-12-16 22:19:25 +0000 )edit

I apologize for not being clear. I made the entry in the configuration using nm-connection-editor for the access point. When I was testing WPA[12] I put in the passphrase in the entry. When I was testing WEP I put the WEP key and index in the entry. Afterwhich I closed the nm-connection editor.

Stephen ( 2011-12-16 22:26:55 +0000 )edit

I then when to NetworkManager applet icon, clicked to open it and then selected 9west. The NetworkManager closed and started to make the connection. After a certain amount of time I would get the first window asking for the passphrase with the stored passphrase listed in the field.

Stephen ( 2011-12-16 22:28:27 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-12-16 16:07:01 +0000

ztank1013 gravatar image

You may try to run from the command line the network manager connection editor:

sudo nm-connection-editor

then identify and delete the current non working WPA2 connection on the Wireless tab, finally try to manually recreate it using the Add... button.

Most importantly, remember to setup at this point the password in to the Wireless Security tab.

I had a similar problem on my old f16 laptop installation and unfortunately I had to repeat this manual configuration on each new WPA2 access point I had to use.

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2011-12-16 15:16:18 +0000

Seen: 11,727 times

Last updated: Dec 18 '11