Ask Your Question
1

Fedora 22 split my mouse into two devices! One for the pointer, and one for scrolling. How to fix it?

asked 2015-06-29 19:36:23 -0600

stshk gravatar image

updated 2015-06-30 10:38:22 -0600

Hello=)

After installing Fedora 22 into Vmware Workstation I noticed that it's hard to scroll. A big threshold before actual scrolling kicks in appeared. And scrolling while moving the mouse is completely ignored by the system.

Some output:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ VMware VMware Virtual USB Mouse           id=7    [slave  pointer  (2)]
⎜   ↳ VirtualPS/2 VMware VMMouse                id=9    [slave  pointer  (2)]               <------THIS ONE IS JUST SCROLLING
⎜   ↳ VirtualPS/2 VMware VMMouse                id=10   [slave  pointer  (2)]       <------THIS ONE MOVES THE CURSOR
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=8    [slave  keyboard (3)]

$ xinput list-props 9
Device 'VirtualPS/2 VMware VMMouse':
    Device Enabled (118):   1
    Coordinate Transformation Matrix (120): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (251): 0.000000
    libinput Accel Speed Default (252): 0.000000
    libinput Natural Scrolling Enabled (253):   0
    libinput Natural Scrolling Enabled Default (254):   0
    libinput Send Events Modes Available (236): 1, 0
    libinput Send Events Mode Enabled (237):    0, 0
    libinput Send Events Mode Enabled Default (238):    0, 0
    libinput Left Handed Enabled (255): 0
    libinput Left Handed Enabled Default (256): 0
    libinput Scroll Methods Available (257):    0, 0, 1
    libinput Scroll Method Enabled (258):   0, 0, 0
    libinput Scroll Method Enabled Default (259):   0, 0, 0
    libinput Button Scrolling Button (260): 0
    libinput Button Scrolling Button Default (261): 0
    Device Node (239):  "/dev/input/event3"
    Device Product ID (240):    2, 19

$ xinput list-props 10
Device 'VirtualPS/2 VMware VMMouse':
    Device Enabled (118):   1
    Coordinate Transformation Matrix (120): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Calibration Matrix (266):  1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Calibration Matrix Default (267):  1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Natural Scrolling Enabled (253):   0
    libinput Natural Scrolling Enabled Default (254):   0
    libinput Send Events Modes Available (236): 1, 0
    libinput Send Events Mode Enabled (237):    0, 0
    libinput Send Events Mode Enabled Default (238):    0, 0
    libinput Left Handed Enabled (255): 0
    libinput Left Handed Enabled Default (256): 0
    libinput Scroll Methods Available (257):    0, 0, 1
    libinput Scroll Method Enabled (258):   0, 0, 1
    libinput Scroll Method Enabled Default (259):   0, 0, 1
    libinput Button Scrolling Button (260): 2
    libinput Button Scrolling Button Default (261): 274
    libinput Middle Emulation Enabled (262):    0
    libinput Middle Emulation Enabled Default (263):    0
    Device Node (239):  "/dev/input/event2"
    Device Product ID (240):    2, 19

How can I make one device do both (moving the cursor and scrolling) and delete the other?

Thanks=)

PS: Could someone tell me how to mark console lines so ... (more)

edit retag flag offensive close merge delete

Comments

I highlighted the relevant lines and pressed the button above the text area labeled "101010". Anyway, try removing xorg-x11-drv-libinput.

randomuser gravatar imagerandomuser ( 2015-06-30 10:43:16 -0600 )edit

Thanks=) Removing xorg-x11-drv-libinput didn't affect anything=0

stshk gravatar imagestshk ( 2015-07-05 13:27:35 -0600 )edit

fwiw, if libinput sees two devices it's because the kernel exports two devices. removing the xorg libinput driver has no effect, evdev and all other drivers would see two kernel devices too.

whot gravatar imagewhot ( 2015-07-15 17:28:23 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-07-19 05:37:15 -0600

stshk gravatar image

IT'S WORKING!!!!=DDD

deleting xorg-x11-drv-libinput was a mistake. after that mouse is handled by evdev and all gets even worse. after the last dnf update libinput somehow handles my split mouse correctly=)

edit flag offensive delete link more

Comments

maybe version 4.0.8 kernel + modules fixed it=)

stshk gravatar imagestshk ( 2015-07-19 05:38:50 -0600 )edit

after update to kernel 4.1.3 it's not working again...=((

stshk gravatar imagestshk ( 2015-07-31 11:56:41 -0600 )edit
0

answered 2015-07-15 17:20:59 -0600

whot gravatar image

can you please file a bug for this? sounds like something we need to fix though I don't know what the cause of it is just yet.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-29 19:36:23 -0600

Seen: 749 times

Last updated: Jul 19 '15