Ask Your Question

how to keep Fedora 22 updates from breaking Broadcom BCM4312 wireless?

asked 2015-06-30 14:21:49 +0000

MarkL gravatar image

updated 2015-06-30 15:28:34 +0000

I upgraded to Fefora 22 since I am having the same problem that keep recurring. the networking keep getting broken.

when i would update with Yum I would not have a problem with getting rpmfusion to load the wl module and keep the wireless working. when I update with dnf the wl module does not get loaded. I have gotten the rpmfusion repositories to install. but I still have a problem that keep occurring. when I try to install the kmod-wl i get following error.

# dnf install kmod-wl
Last metadata expiration check performed 1:37:31 ago on Tue Jun 30 07:20:35 2015.
Error: package kmod-wl- requires kmod-wl-4.0.4-301.fc22.x86_64 >=, but none of the providers can be installed

So naturally i try the following install

# dnf install kmod-wl-4.0.4-301.fc22.x86_64
Last metadata expiration check performed 1:40:43 ago on Tue Jun 30 07:20:35 2015.
Error: package kmod-wl-4.0.4-301.fc22.x86_64- requires kernel-uname-r = 4.0.4-301.fc22.x86_64, but none of the providers can be installed

That is the problem the kernel in the latest update is 4.0.6-300.fc22.x86_64 which keeps me from loading the wl module and driver.

I have tried to use the Broadcom STA driver but I get errors with that also. I can not get passed the "make" command. here is the error I get.

[root@localhost-lahmann hybrid-v35_64-nodebug-pcoem-6_30_223_248]# make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory '/usr/src/kernels/4.0.6-300.fc22.x86_64'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  CC [M]  /home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.o
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c: In function ‘wl_alloc_linux_if’:
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c:1310:64: error: macro "alloc_netdev" requires 4 arguments, but only 3 given
  dev = alloc_netdev(sizeof(priv_link_t), intf_name, ether_setup);
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c:1310:8: error: ‘alloc_netdev’ undeclared (first use in this function)
  dev = alloc_netdev(sizeof(priv_link_t), intf_name, ether_setup);
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c:1310:8: note: each undeclared identifier is reported only once for each function it appears in
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c: In function ‘wl_dump_ver’:
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c:2049:3: error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time]
/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.c:2049:13: error: macro "__TIME__" might prevent reproducible builds [-Werror=date-time]
cc1: some warnings being treated as errors
scripts/Makefile.build:258: recipe for target '/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.o' failed
make[2]: *** [/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248/src/wl/sys/wl_linux.o] Error 1
Makefile:1394: recipe for target '_module_/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248' failed
make[1]: *** [_module_/home/mlahmann/hybrid-v35_64-nodebug-pcoem-6_30_223_248] Error 2
make[1]: Leaving directory '/usr/src/kernels/4.0.6-300 ...
edit retag flag offensive close merge delete


kmod-wl and akmod-wl is the broadcom sta driver, fwiw.

randomuser ( 2015-06-30 15:24:19 +0000 )edit

2 answers

Sort by » oldest newest most voted

answered 2015-07-01 03:16:27 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

The fix is very easy. I used the suggestion from the help of "aeperzt." Here is how you can get the Broadcom BCM4312 to work.

1) login as a root user or sudo which will ask for root password. Then as a root user you will be allow root permissions to enter commands to install. The "#" symbol is the command prompt for a root user.

Enter the following commands

# dnf update --best --allowerasing

This will install the correct kernel-devel package for the current kernel.

# akmods --force

Checking kmods exist for 4.0.6-300.fc22.x86_64 [ OK ] Building and installing wl-kmod [ OK ]

# modprobe wl

After this the WiFi light comes on and finds my network.

Thank everone for their help.

edit flag offensive delete link more


When I try this it says modprobe: ERROR: could not insert 'wl' : Unknown symbol in module, or unknown parameter (see dmesg) and dmesg says the module verification failed: signature and/or required key missing - tainting kernel I have also posted this as a seperate question here https://ask.fedoraproject.org/en/ques... any ideas?

lindsaymacvean ( 2015-07-04 21:16:20 +0000 )edit

what I entered was the command line command at the root command prompt. akmods --force which gave me the following response. Checking kmods exist for 4.0.4-303.fc22.x86_64 [ OK ] Building and installing wl-kmod then I entered the following command at the root command prompt

modprobe wl everything worked. Did you have RPM fusion free and non-free repositories loaded. to load the repositories. use the following commands for the free repositories. wget http://download1.rpmfusion.org/free/f... dnf install rpmfusion-free-release-22.noarch.rpm

MarkL ( 2015-07-06 03:56:59 +0000 )edit

For the non-free RPM fusion use the following commands wget http://download1.rpmfusion.org/nonfre... dnf install rpmfusion-nonfree-release-22.noarch.rpm you also have to have the kernel module 4.04.303.fc22x86_64 installed

Then do the commands akmods --force the after it finishes enter the command modprobe wl

MarkL ( 2015-07-06 04:20:43 +0000 )edit

Thankyou SOLVED. I uninstalled kmod-wl akmod-wl then reinstalled both followed your instructions (although it did not show Building and installing wl-kmod and the final touch for my Dell Inspiron 1545 was to hit ctrl + F2 and this activated manual wifi switch and wifi appeared :)

lindsaymacvean ( 2015-07-06 12:41:45 +0000 )edit

Sorry, that I had to rework the post. I am new to posting and I sometimes get unwanted results. I am glad to help you work through your problem.

MarkL ( 2015-07-07 03:55:17 +0000 )edit

answered 2015-06-30 15:47:39 +0000

To avoid this you need to install akmod to know why an the difference look at https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more



Thank you for your help. The akmod-wl work well.

MarkL ( 2015-07-01 03:09:21 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2015-06-30 14:21:49 +0000

Seen: 10,382 times

Last updated: Nov 05 '15