English
Ask Your Question
1

How do I enable tapping on my touchpad when touchpad settings are not shown under system settings?

asked 2015-07-15 10:51:25 +0000

Jekishan gravatar image

updated 2015-07-15 14:30:53 +0000

I installed fedora 22 32-bit workstation distribution using live dvd in sony vaio vgn-cs24gh recently. On starting it after installation, I found that though scrolling is possible using touchpad but I am not able to click on it. Moreover, "touchpad" settings are also not shown in the "mouse and touchpad" settings. I have synaptics installed also(xorg-x11-drv-synaptics). I have also installed xorg-x11-drv-libinput.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-07-16 06:58:35 +0000

There's more than one way of doing this; take a look at the ArchWiki for more in-depth tips.

Using xinput

First, list your device(s), for example, here's my output:

$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
⎜   ↳ HP Bluetooth Mouse X4000b                 id=14   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=13   [slave  keyboard (3)]

Next, list the properties available to your device

$ xinput list-props "SynPS/2 Synaptics TouchPad"
Device 'SynPS/2 Synaptics TouchPad':
        Device Enabled (144):   1
        Coordinate Transformation Matrix (146): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Tapping Enabled (276): 1
        libinput Tapping Enabled Default (277): 0
        libinput Accel Speed (278):     -0.800000
        libinput Accel Speed Default (279):     0.000000
        libinput Natural Scrolling Enabled (280):       0
        libinput Natural Scrolling Enabled Default (281):       0
        libinput Send Events Modes Available (261):     1, 1
        libinput Send Events Mode Enabled (262):        0, 0
        libinput Send Events Mode Enabled Default (263):        0, 0
        libinput Left Handed Enabled (282):     0
        libinput Left Handed Enabled Default (283):     0
        libinput Scroll Methods Available (284):        1, 1, 0
        libinput Scroll Method Enabled (285):   1, 0, 0
        libinput Scroll Method Enabled Default (286):   1, 0, 0
        Device Node (264):      "/dev/input/event4"
        Device Product ID (265):        2, 7

NOTE instead of xinput list-props "SynPS/2 Synaptics TouchPad", you could also use the ID number (11, in this case):

$ xinput list-props 11

Then, to enable tapping, you'll notice once again a number next to the property "Tapping Enabled" (276). You can use the number or the property's name in quotes

$ xinput set-prop 11 "Tapping Enabled" 1

or

$ xinput set-prop 11 276 1

Finally, as a sidenote, to disable it, replace the number 1 at the end with a zero.

edit flag offensive delete link more

Comments

2

fwiw the set-prop command has the wrong property, it's "libinput Tapping Enabled", not just Tapping Enabled.

whot ( 2015-07-28 04:13:57 +0000 )edit
0

answered 2015-07-15 22:32:54 +0000

whot gravatar image

usually when the touchpad doesn't show up in the system settings the cause is that the kernel doesn't send the "magic knock" to the touchpad device to switch it into vendor-specific raw mode. without that, the device's firmware will emulate a normal PS/2 mouse.

you can verify this with a simple "xinput list", you'll probably see a "PS/2 Generic Mouse" or something similar. You can doubly verify this by running evemu-record against that device and check if any events are forthcoming when you use the touchpad.

if that's the case, you'll need to file a kernel bug (attach your dmesg output) and wait for the kernel to support this touchpad. once that is done, libinput and synaptics will just work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2015-07-15 10:51:25 +0000

Seen: 2,421 times

Last updated: Jul 15 '15