English
Ask Your Question
0

Fedora22 - Power Management

asked 2015-07-15 12:27:43 +0000

fvtssnow gravatar image

Good afternoon , are there any power management tools ?

I have a few problems that go like this : 1. I cant find from where to set the power on : balanced , power save , performance 2. If i am streaming a movie after 15 min the laptops screen turns black but it wont hybernate or suspend .. 3. the fact that after the movie ends it wont suspend ..but it will stay awake if I turn the above option off I tried searching and found something around here but nothing that is useful to me

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-07-15 15:51:03 +0000

updated 2015-07-15 15:51:32 +0000

You can install tuned : sudo dnf install tuned then sudo systemctl start tuned and sudo systemctl enable tuned

Then choose your profile :

  • tuned-adm active => active profile
  • tuned-adm list => list of available profiles
  • tuned-adm profile powersave => to active one.

To check the temperature : use sensors (sudo dnf install lm_sensors)

edit flag offensive delete link more
0

answered 2015-07-15 16:32:47 +0000

fvtssnow gravatar image

acpitz-virtual-0 Adapter: Virtual device temp1: +39.0°C (crit = +128.0°C) temp2: +0.0°C (crit = +128.0°C) temp3: +37.0°C (crit = +128.0°C) temp4: +43.0°C (crit = +128.0°C) temp5: +0.0°C (crit = +128.0°C) temp6: +127.0°C (crit = +128.0°C)

radeon-pci-0100 Adapter: PCI adapter temp1: N/A (crit = +120.0°C, hyst = +90.0°C)

coretemp-isa-0000 Adapter: ISA adapter Physical id 0: +41.0°C (high = +87.0°C, crit = +105.0°C) Core 0: +36.0°C (high = +87.0°C, crit = +105.0°C) Core 1: +38.0°C (high = +87.0°C, crit = +105.0°C) Core 2: +40.0°C (high = +87.0°C, crit = +105.0°C) Core 3: +41.0°C (high = +87.0°C, crit = +105.0°C

Thats the temps I get from sensors .

Any idea about the hibernate option ?

Basically I want to be able to watch a movie without the screen going black , and if i fall asleep i want the computer to go into hybernation if there is no activity

edit flag offensive delete link more

Comments

For hibernation after an idle time, you can try :

sudo vi /etc/systemd/logind.conf

Then uncomment and modify these 2 lines :

IdleAction=hibernate
IdleActionSec=30min

More info man 5 logind.conf

yolo ( 2015-07-15 18:41:37 +0000 )edit

im in the menu but im not sure what to do even though looks simple

fvtssnow ( 2015-07-15 19:57:14 +0000 )edit

how do i uncomment ?

fvtssnow ( 2015-07-15 19:57:53 +0000 )edit

In the Terminal, run the command sudo vi /etc/systemd/logind.conf In the editor, move till the line #IdleAction=ignore with the arrows, press i (insert mode) and remove the character # (the line will be uncommented) and replace ignore by hibernate. Do the same with second line. Once done, press Escap (to quite the insert mode) and press ZZ (Z caps 2 times to save and quite).

yolo ( 2015-07-15 20:47:34 +0000 )edit

so I did the change ..nothing happened I got an error saying there is another file ... so I did rm /etc/systemd/logind.conf ... but now both files are gone ? and there is no more file :D , ideas on how to fix this ?

EDIT : I fixed it somehow recovered the file . but still says there are 2 of them

fvtssnow ( 2015-07-16 08:53:23 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2015-07-15 12:27:43 +0000

Seen: 193 times

Last updated: Jul 15 '15