Ask Your Question
2

Fedora 22 DNF timeout

asked 2015-07-19 16:34:16 -0500

Richard87 gravatar image

I just installad Fedora 22 and DNF (yum's replacement) is performing terrible.

9 out of 10 request fails out of timeout, with random effect specifying IPv4 or not. The problem seems to be that DNF can't pick a proper mirror nad often pick a non-responding one, or a terribly slow one.

Feil: Error downloading packages:
Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f22&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]

Also, I think IPv6 is caussing some trouble, so it has been deactivated on my system. Restarts dosn't change anything either...

(Before I found ask.fedoraproject.org I asked the same question on stackexhange first: http://serverfault.com/questions/7069... )

edit retag flag offensive close merge delete

Comments

curl http://icanhaztrace.com may show up some issues. I too suspect your DNS provider sucks. It may be time to ditch them, or host your own dns cache.

NuuN gravatar imageNuuN ( 2015-07-19 17:05:20 -0500 )edit

I agree with the posting, dnf is much slower than yum. Further it often tries to connect to a high/random port on the mirror server, which our company firewall doesn't allow. I never had this problem with yum.

polywogsys gravatar imagepolywogsys ( 2015-07-24 11:12:15 -0500 )edit

@polywogsys, I am quite new to Fedora. Haven't used an RPM tool since Mandrake's urpmi. But, dnf is always trying to connect in order to keep metadata fresh. Unless they are doing strict whitelisting, your company firewall is dumb. If they allow any <1024 to go through but do not allow any >9000, they are being lazy.

dnf has proxy options for such cases. man dnf.plugin.config-manager

NuuN gravatar imageNuuN ( 2015-07-24 11:33:22 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-07-20 03:08:10 -0500

NikTh gravatar image

updated 2015-07-20 03:10:27 -0500

(Before I found ask.fedoraproject.org I asked the same question on stackexhange first: http://serverfault.com/questions/7069.. . )

So, you have already found the answer , right?

Updating to googles DNS Servers worked like a charm on the first try! Thank you! If you post an answer I will accept it, also if you have tips on public DNS it would be highly appreciated :)

If you don't know how to permanently change the DNS servers, via NetworkManager, have a look at this answer.

As for DNS service, I'm using OpenDNS(has nothing to do with OpenSource) for some time now and I have no problems.

edit flag offensive delete link more

Comments

Thanks, yup, it was all in my DNS settings...

Richard87 gravatar imageRichard87 ( 2015-07-20 09:47:35 -0500 )edit

There are many other fast ones to chose from too:

Symantec also offers free, basic DNS.

NuuN gravatar imageNuuN ( 2015-07-20 09:49:18 -0500 )edit

Thanks! I'm looking for some good DNS servers, It's a shame that my ISP is not up to the task :/

Richard87 gravatar imageRichard87 ( 2015-07-20 09:51:03 -0500 )edit

You could mix more them. The traditional maximum are 3 entries. So 1 from OpenDNS, 1 from Yandex, 1 from Google (8.8.8.8; 8.8.4.4).

NuuN gravatar imageNuuN ( 2015-07-20 09:53:46 -0500 )edit

Yup, Thinking I should go for OpenNIC as #1, and Google for #2 nd #3... (a little anonymity would be nice :) )

Richard87 gravatar imageRichard87 ( 2015-07-20 09:59:02 -0500 )edit
0

answered 2016-07-30 04:26:46 -0500

This is just a temporary issue which you are having,keep on repeating the command. Or , it may be that you have a poor internet connection.Also try

dnf clean all
dnf clean packages

keep on trying repeatedly.It may work

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-19 16:34:16 -0500

Seen: 3,778 times

Last updated: Jul 20 '15