Ask Your Question
2

cannot install nvidia-libs.i686

asked 2015-07-25 03:36:53 -0500

mifth gravatar image

updated 2015-07-25 11:34:00 -0500

I have 64 bit machine. But to run Steam i need 32 bit libs. I tried to install 32 bit libs as was suggested there: https://ask.fedoraproject.org/en/ques... But i cannot install them.

Here is log:

[root@myhost mifth]# dnf install xorg-x11-drv-nvidia-libs.i686
langpacks: No languages are enabled
Failed to synchronize cache for repo 'heliocastro-lxqt' from 'https://copr-be.cloud.fedoraproject.org/results/heliocastro/lxqt/fedora-22-x86_64/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Last metadata expiration check performed 1:10:47 ago on Sat Jul 25 10:21:36 2015.
Error: package kmod-nvidia-340xx-4.0.8-300.fc22.x86_64-1:340.76-2.fc22.12.x86_64 requires nvidia-340xx-kmod-common >= 1:340.76, but none of the providers can be installed

I have Fedora22. Thanks.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-07-25 11:39:02 -0500

mifth gravatar image

updated 2015-09-04 11:57:44 -0500

It seems in Fedora 22 I should install a lib like this:

dnf install xorg-x11-drv-nvidia-libs.i686

As i have 340xx driver installed. You can also set your own version according to your videocard from here http://rpmfusion.org/Howto/nVidia latest/340/304/173

Thanks.

edit flag offensive delete link more

Comments

So you managed to install xorg-x11-drv-nvidia-340xx-libs.i686

geforce gravatar imagegeforce ( 2015-09-05 04:52:16 -0500 )edit
1

answered 2015-10-07 14:52:28 -0500

jake gravatar image
$ sudo dnf install steam-noruntime

will setup all necessary 32bit libs for steam

edit flag offensive delete link more
1

answered 2015-09-05 17:06:55 -0500

syncer gravatar image

Had the same problem. Installed the nvidia driver over the negativo17 repo. I solved the problem by downloading the correct 32bit lib directly. http://negativo17.org/repos/nvidia/fe... (I'm using akmod-nvidia-355.11-1.fc22.x86_64) steam works now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-25 03:36:07 -0500

Seen: 618 times

Last updated: Oct 07 '15