English
Ask Your Question
0

Why doesn't my key show up in xev?

asked 2011-11-27 22:47:41 +0000

thomas gravatar image

Using a Thinkpad T400s (Fedora 16, 64bit) my microphone mute key doesn't trigger any response at all with xev.

Any ideas? It used to work in Fedora 15 and works with Linux Mint 12 and Ubuntu 11.10!

(For more information, see https://bugzilla.redhat.com/show_bug.cgi?id=757365)

edit retag flag offensive close delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2011-11-30 04:48:09 +0000

whot gravatar image

Two reasons why keys do not show up in xev or do not work at all.

xev simply registers for key events and then prints them as the X server delivers them to xev - provided the window is in focus. If a key combination is grabbed by another application (usually those that handle shortcuts, e.g. gnome-settings-daemon) the event is not delivered to the current focus window but to the grabbing client instead. That's why you never see Alt+Tab show up in xev (only the initial Alt press), the same with volume keys, brightness keys, and general shortcuts.

Second reason, applies to the microphone mute key: X cannot handle keycodes above 255, and X keycodes are kernel keycode + 8 for historical reasons. KEY_MICMUTE is 248 in linux/input.h which makes it 256 in X - above the limit. It gets dropped in the server since we cannot deliver it to a client. It's a well known problem but incredibly hard to fix. See upstream bugzilla https://bugs.freedesktop.org/show_bug.cgi?id=11227#c45">https://bugs.freedesktop.org/show_bug.cgi?id=11227

Keycodes can be checked easily with the evtest utility.

edit flag offensive delete publish link more
0

answered 2011-11-28 20:00:08 +0000

See if this wiki page is of any assistance :

http://www.thinkwiki.org/wiki/Howtogetspecialkeystowork

Unfortunately it claims "To check if a key is being handled by Xorg, start xev and press the key. If you do not see any output from the keypress it is not handled. If it is handled you can configure the key in Gnome with gnome-keybinding-properties"

I am not sure if there is a work around or not, I do not have the hardware to test.

edit flag offensive delete publish link more
0

answered 2011-12-05 13:36:05 +0000

thomas gravatar image

By the way, I found a workaround: http://forums.fedoraforum.org/showpost.php?p=1536096&postcount=7

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
1 follower

Stats

Asked: 2011-11-27 22:47:41 +0000

Seen: 1,733 times

Last updated: Dec 05 '11