Ask Your Question
1

Editing GRUB2 timeout (standby time)

asked 2015-08-21 08:36:00 -0500

fabriciodsb gravatar image

Hello. I've been trying to change the default timeout seconds from 5 seconds to 1, but it's not been applied to the boot file itself.

What I've done:

sudo gedit /etc/default/grub

Then edited this line to be like this:

GRUB_TIMEOUT=1

Then updated GRUB2 with this command:

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

But nothing changes when I reboot it.

Any ideas that might help?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

1

After you re-generate your /boot/grub2/grub.cfg does option "set timeout" change?

masteroman gravatar imagemasteroman ( 2015-08-21 13:38:38 -0500 )edit

What is the outcome of that command? Do you see your edited grub saved, or when you open it again it still shows 5? That command works for BIOS firmware, if you have UEFI, use:

# sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
pal1 gravatar imagepal1 ( 2016-04-13 05:15:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-27 07:58:34 -0500

whales gravatar image

"pal1" 's solution worked for me as well.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-08-21 08:36:00 -0500

Seen: 3,508 times

Last updated: Aug 21 '15