English
Ask Your Question
0

Fedora 16 software source disabled

asked 2011-11-21 17:21:31 +0000

Scott gravatar image

I am using Fedora 16. And I have not been receiving software updates. I checked my software settings and noticed Fedora 16 -i386 was unchecked. When I try to check it I receive the following error.

Could not contact source 'fedora'

I have a working internet connection. How can I enable the software source fedora 16 - i386?

edit retag flag offensive close delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-21 18:10:56 +0000

tjw344 gravatar image

updated 2011-11-21 18:36:00 +0000

I am not sure about your specific problem. You might check your fedora.repo file in /etc/yum.repos.d . I wanted to attach it, but that requires more karma(i dunno why). so here is a link to a copy:

fedoraforumthread271496

It should work for you. If you like you can cp it to /etc/yum.repos.d/fedora.repo . You can do that by: 1)open terminal and login as root 2)type: nano /etc/yum.repos.d/fedora.repo 3)save a copy by pressing ctrl + x , and then changing the name to fedora.repo.bak 4)then again nano /etc/yum.repos.d/fedora.repo and delete the contents 5)copy contents from the link above 6)hit ctrl and x , then y to save as /etc/yum.repos.d/fedora.repo Then try:

sudo yum clean all && sudo yum update

Hope this helps.

edit flag offensive delete publish link more

Comments

1

I have tried the above fix and I am still receiving the same error. I was able to fix it by changing https in the .repo files to http. I got this suggestion from http://www.fedoraforum.org/forum/showthread.php?t=260273 . I don't know why this worked and if it is ok. Thanks for your help.

Scott ( 2011-11-21 20:16:47 +0000 )edit

My mistake, I forgot about that. I had to do that too. I don't know if it is the proper way to do things though. Maybe somebody else knows?

tjw344 ( 2011-11-22 04:54:54 +0000 )edit
0

answered 2011-11-26 04:21:36 +0000

This might be a bug with the recent nss update.

rpm -q nss

should tell you. If you have 3.13, it's likely this issue. You can solve it with:

yum --setopt=sslverify=false downgrade nss*

edit flag offensive delete publish link more
0

answered 2011-11-22 15:05:27 +0000

I had the same problems the last days but now it works fine.

edit flag offensive delete publish link more
0

answered 2011-11-21 17:58:51 +0000

Can you please open up a terminal and get me the output of:

su -c 'yum repolist'
edit flag offensive delete publish link more

Comments

[scott@localhost ~]$ su -c 'yum repolist' Password: Loaded plugins: langpacks, presto, refresh-packagekit Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again [scott@localhost ~]$

Scott ( 2011-11-21 18:01:49 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
1 follower

Stats

Asked: 2011-11-21 17:21:31 +0000

Seen: 2,097 times

Last updated: Nov 26 '11