Ask Your Question
1

How to reinstall Yum / DNF completely?

asked 2015-09-24 15:55:39 -0500

paladini gravatar image

My DNF is very broken and VERY, VERY, VERY slow. I don't know what's the cause, but when I try to run dnf install or dnf update I must wait a long time until it print something in the Terminal (> 1 min).

Quite often I can't install "Important OS updates" and when I try to run DNF commands I got erros that abort the current dnf operation, sometimes.

How can I reinstall Yum / DNF completely?

edit retag flag offensive close merge delete

Comments

2

So, this doesn't necessarily mean that dnf is broken; it could be a latency issue with the mirror being selected, for example. Have you tried enabling the fastestmirror option in /etc/dnf/dnf.conf? (See my answer in that question for the instructions). If that doesn't help, we can try some more troubleshooting before attempting to reinstall your package manager.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-24 17:02:22 -0500 )edit

This didn't worked at all, my DNF still very slow. It's fast to download and fetch repositories and packages, but right after I digit dnf <something> and press Enter, it looks like DNF is waiting for something else or frozen for some reason. It takes very long time until it starts to fetch repositories, but later is very fast.

paladini gravatar imagepaladini ( 2015-09-25 14:19:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-09-25 15:05:15 -0500

paladini gravatar image

I've solved the problem and I didn't have to uninstall Yum/ DNF.

The problem is that a repository (ozonos) was failing to synchronize every time:

Failed to synchronize cache for repo 'ozonos' from '[u'http://goodies.ozon-os.com/repo/20/']': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.

I've a lot of other repositories that is failing to synchronize, but when I removed this one my DNF command start working properly again. To disable this repository I just run:

sudo yum-config-manager --disable ozonos

Anyway, thank you for your support, @bitwiseoperator!

edit flag offensive delete link more

Comments

1

Nice work! Thanks for answering your own question!

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-25 22:08:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-24 15:55:39 -0500

Seen: 1,022 times

Last updated: Sep 25 '15