WOL disabled. Fedora 22

asked 2015-10-10 03:27:06 -0500

olegon.ru gravatar image

updated 2015-10-10 15:40:48 -0500

mether gravatar image

uname -a Linux 4.1.10-200.fc22.x86_64 #1 SMP Mon Oct 5 14:22:49 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 04) DeviceName: Onboard LAN Subsystem: ASUSTeK Computer Inc. Device 859f Kernel driver in use: e1000e Kernel modules: e1000e

cat /sys/class/net/eno1/device/power/wakeup disabled

Why?!? Some time ago it works very well... What is the right way to switch it to enabled every time of if-up?

edit retag flag offensive close merge delete

Comments

Will start

!/bin/bash

/usr/sbin/ethtool -s eno1 wol g echo enabled> /sys/class/net/eno1/device/power/wakeup

hourly as workaround... (Host sleep at 2 hours of inactivity)

olegon.ru gravatar imageolegon.ru ( 2015-10-11 02:42:36 -0500 )edit