Ask Your Question
1

Linksys Wireless-G USB network adapter Fedora 17 x64

asked 2012-08-15 21:22:33 -0500

pablocampis gravatar image

updated 2012-08-16 06:24:13 -0500

hhlp gravatar image

Hello, I installed Fedora 17 x64 on my desktop computer. For Wi-fi I use a Linksys USB adapter. I noticed that fedora detected the device and installed the driver because I can connect to my home network. The problem is that the internet speed is very slow in fedora, i have download rates of 3 kbps (I have a 3MB connection). In windows the speed is regular (as in my other home computers). The driver that Fedora installed is RT2500, is this the correct driver? If not, What can I do?

Thanks in advance.

PS: The information from lsusb is this:

Bus 001 Device 004: ID 13b1:000d Linksys WUSB54G v4 802.11g Adapter [Ralink RT2500USB]
Bus 002 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 002 Device 003: ID 15d9:0a4c Trust International B.V. USB+PS/2 Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The information of iwconfig is this:

lo        no wireless extensions.

em1       no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"INFINITUM0066"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:25:3C:91:82:92   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=63/70  Signal level=-47 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:113  Invalid misc:341   Missed beacon:0
edit retag flag offensive close merge delete

Comments

Could you also output the output of ``ifconfig wlan0'' to see the counters of TX and RX errors.

rickvanderzwet gravatar imagerickvanderzwet ( 2013-06-05 03:27:51 -0500 )edit

are your download speeds you mentioned from the windows boxes using the same ralink adapter if so then I would recommend remove and reinstall the rt2500 firwmare or check ralink's page and ensure the driver version in fedora repo is the latest ralink is pushing if not grab the .rpm or tarball and reinstall that set of drivers also the readout you ran was iwconfig try iFconfig wlan0

linuxmodder gravatar imagelinuxmodder ( 2014-02-25 02:15:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-13 09:20:28 -0500

lobocode gravatar image

Why? because fedora 17 and not 20? because clinging to outdated versions? Try it : sudo systemctl disable firewalld.service , sudo systemctl restart network.service, and use ABRT to check possible errors or bugs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-15 21:22:33 -0500

Seen: 1,445 times

Last updated: Mar 13 '14