Ask Your Question
2

Unwanted suspend when locking screen using GNOME

asked 2015-10-14 07:51:11 -0500

Aeyoun gravatar image

updated 2015-10-14 12:21:52 -0500

My Lenovo Yoga 3 Pro laptop suspends automatically after some idle time even thought I’ve disabled this. It also suspends after using the lock button in the GNOME menu. I don’t want my laptop suspending when it’s connected to AC. I can’t really figure out what is wrong here and I believe my setup is pretty vanilla.

Can anyone tell me how to disable this unwanted behavior?

$ # GNOME Settings: Power
$ gsettings list-recursively org.gnome.settings-daemon.plugins.power
org.gnome.settings-daemon.plugins.power button-power 'suspend'
org.gnome.settings-daemon.plugins.power critical-battery-action 'hibernate'
org.gnome.settings-daemon.plugins.power priority 0
org.gnome.settings-daemon.plugins.power idle-dim true
org.gnome.settings-daemon.plugins.power button-hibernate 'hibernate'
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'
org.gnome.settings-daemon.plugins.power button-sleep 'hibernate'
org.gnome.settings-daemon.plugins.power button-suspend 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'nothing'
org.gnome.settings-daemon.plugins.power idle-brightness 30
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
org.gnome.settings-daemon.plugins.power active true

# # systemd
# systemd-inhibit --list
     Who: gdm (UID 42/gdm, PID 1391/gnome-settings-)
    What: handle-power-key:handle-suspend-key:handle-hibernate-key
     Why: GNOME handling keypresses
    Mode: block

     Who: gdm (UID 42/gdm, PID 1391/gnome-settings-)
    What: sleep
     Why: GNOME needs to lock the screen
    Mode: delay

     Who: Telepathy (UID 42/gdm, PID 1416/mission-control)
    What: shutdown:sleep
     Why: Disconnecting IM accounts before suspend/shutdown...
    Mode: delay

     Who: Telepathy (UID 1000/d, PID 1995/mission-control)
    What: shutdown:sleep
     Why: Disconnecting IM accounts before suspend/shutdown...
    Mode: delay

     Who: d (UID 1000/d, PID 1873/gnome-settings-)
    What: handle-power-key:handle-suspend-key:handle-hibernate-key
     Why: GNOME handling keypresses
    Mode: block

     Who: NetworkManager (UID 0/root, PID 828/NetworkManager)
    What: sleep
     Why: NetworkManager needs to turn off networks
    Mode: delay

     Who: GNOME Shell (UID 1000/d, PID 1903/gnome-shell)
    What: sleep
     Why: GNOME needs to lock the screen
    Mode: delay

     Who: d (UID 1000/d, PID 1873/gnome-settings-)
    What: sleep
     Why: GNOME needs to lock the screen
    Mode: delay

8 inhibitors listed.

# # All defaults in logind.conf
# tail -n20 /etc/systemd/logind.conf
[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
edit retag flag offensive close merge delete

Comments

Same problem here on another ThinkPad Helix as well: ArchLinux GDM/Gnome 3.18.3. I was able to keep it from suspending by editing the Power settings in the standard Gnome Control Panel to not blank the screen, and turning off all suspends. But then I get no lock screen action.

eduncan911 gravatar imageeduncan911 ( 2016-01-29 23:00:28 -0500 )edit

Same problem here with Sony Vaio Fit 13, Locking screen or switching users suspends the system. the only work around is to disable org.gnome.settings-daemon.plugins.power by settings activate to false

https://ask.fedoraproject.org/en/ques...

boynux gravatar imageboynux ( 2016-02-25 21:12:47 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-11-06 02:35:21 -0500

Pawel gravatar image

I have the same problem with Ubuntu Gnome 15.10 (Gnome Shell 3.16) on ThinkPad Helix. System always suspend just after screen lock... tried almost everything... Any idea why?

edit flag offensive delete link more

Comments

I haven’t gotten anywhere with this yet.

Aeyoun gravatar imageAeyoun ( 2015-11-27 07:38:49 -0500 )edit

Hey there!

I managed to disable this annoying behaviour by disabling on dconf screensaver-proxy under org/gnome/settings-daemon/plugins/

I hop this help you guys as it was a pain in the ... head for me.

Patricio M Dorantes Jamarne gravatar imagePatricio M Dorantes Jamarne ( 2017-12-24 08:33:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-10-14 07:51:11 -0500

Seen: 2,037 times

Last updated: Oct 14 '15