Ask Your Question
2

Fedora 23 - Add BCM 43142 support ?

asked 2015-11-05 05:55:55 -0500

.Marcus. gravatar image

updated 2015-11-05 08:32:37 -0500

Hi, i'm new with fedora and i love it. But i could not get the WLAN running on my laptop. With Mint it works, the Mint Team provide the drive on the DVD for Post-installation, it seems this 'Broadcom' Drive, however is a special guest on all distributions :-)

I try to install the BCM 43142 drive as described in various threads, but no luck :-(

Could anyone advise how to get WLAN (BCM 43142, Broadcom) support on fresh installed Fedora 23 ?

Thanks in advance, regards Marcus

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
1

answered 2015-11-05 08:34:30 -0500

aeperezt gravatar image

Broadcom has no free kernel modules so you must use rpmfusion.org , you can install Fedora 22 and install akmod-wl

edit flag offensive delete link more
1

answered 2016-03-27 20:12:42 -0500

hari91 gravatar image

I checked a lot of forums and tried out the steps below:

Enable free and non free RPM fusion repositories

Run - sudo dnf update

Run - sudo dnf install kmod-wl akmods akmod-wl

After rebooting i had two kernels, 4.2.3 and 4.4.6 (initially i had only 4.2.3). the BCM43142 worked on the former but didn't work in the latter.

(make sure you disable the secure boot option in the BIOS)

  1. Then i ran sudo dnf install kernel-devel. After this I rebooted. It worked after that! (while the computer shutdown i pressed F1 to check the commands running in the background - I could see the kmod updates ran on the new kernel).
edit flag offensive delete link more
1

answered 2016-03-27 21:30:50 -0500

sergiomb gravatar image

RPM Fusion on F23 got updates in updates-testing ( yet! ) , maybe is that the problem.

You have a broadcom-wl-6.30.223.271-1.fc23 http://download1.rpmfusion.org/nonfre...

dnf config-manager --set-enable rpmfusion-free-updates-testing rpmfusion-nonfree-updates-testing

Also make sure you have the kernel-devel, of running kernel, installed and not kernel-debug-devel etc etc

dnf install kernel-devel-$(uname -r)
edit flag offensive delete link more
0

answered 2016-03-12 11:01:39 -0500

aurelien gravatar image

That is the script that works on last kernel update (fedora 23) Linux bigfoot 4.4.4-301.fc23.x86_64 #1 SMP Fri Mar 4 17:42:42 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

https://onpub.com/install-broadcom-li...

edit flag offensive delete link more
0

answered 2015-11-05 14:34:39 -0500

.Marcus. gravatar image

Thank you for your answer.

I installed the akmod-wl package, installation finished successful but fedora still not support / display any wifi option.

May be same issue as described here https://ask.fedoraproject.org/en/ques...

It seems the akmod-wl is not updated to latest kernel ?

Thanks, regards Marcus

edit flag offensive delete link more

Comments

1

akmod-wl download the source code of the module and build it, you need to resart or do akmod --force make sure your have installed the kernel-devel libraries.

sudo dnf install kernel-devel

after that restart NetworkManager or the computer so akmod build the module and installed.

look at this https://ask.fedoraproject.org/en/ques...

aeperezt gravatar imageaeperezt ( 2015-11-05 16:04:32 -0500 )edit

Many thanks, that worked ! First i get an error while execute 'akmods --force' * /lib/modules/4.2.3-300.fc23.i686/build: No such file or directory. Stop. Makefile:142: recipe for target 'all' failed

But after some tries and restart it works !

Regards Marcus

.Marcus. gravatar image.Marcus. ( 2015-11-08 02:08:58 -0500 )edit
0

answered 2015-11-28 08:52:36 -0500

updated 2015-12-05 07:01:10 -0500

I'm having the same problem, following upgrade to Fedora 23 from Fedora 22. akmods has always worked on Fedora 22, and when I run 'akmods --force' everything appears to go as normal:

# akmods --force
Checking kmods exist for 4.2.6-301.fc23.x86_64             [  OK  ]
Building and installing wl-kmod                            [  OK  ]

But then when I run 'modprobe wl' I now get an error:

# modprobe wl
modprobe: FATAL: Module wl not found in directory /lib/modules/4.2.6-301.fc23.x86_64

However, when I check in that directory, the file wl.ko appears to be there, in the extras folder, as usual. So I'm baffled...

UPDATE: I found that onpubcom's script worked for me. See https://onpub.com/install-broadcom-li...

edit flag offensive delete link more

Comments

That defenitely works. Do not waste your time, just execute script above (onpub)! Thanks a lot. Everybody should upvote this answer.

Enelar gravatar imageEnelar ( 2016-04-04 10:01:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-11-05 05:55:55 -0500

Seen: 11,485 times

Last updated: Mar 27 '16