Ask Your Question
0

NetworkManager does not connect to wireless networks

asked 2012-01-06 16:46:58 -0500

kenda gravatar image

Heya

I'm having this problem since the installation of F16. I thought there might come updates that solves it, but they didn't. So before filing a bug, maybe you can help me.

When I want to bring up my wireless device (eth1) with NetworkManager, it is immediately turned off again.

Here are the messages of /var/log/messages:

Jan  6 23:30:33 laptop-hl NetworkManager[752]: <info> (eth1): bringing up device.
Jan  6 23:30:33 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): bringing up device.
Jan  6 23:30:33 laptop-hl NetworkManager[752]: <info> WiFi hardware radio set enabled
Jan  6 23:30:33 laptop-hl NetworkManager[752]: <info> WiFi now enabled by radio killswitch
Jan  6 23:30:33 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> WiFi hardware radio set enabled
Jan  6 23:30:33 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> WiFi now enabled by radio killswitch
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): supplicant interface state: starting -> ready
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> (eth1): supplicant interface state: starting -> ready
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): device state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> (eth1): device state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> (eth1): supplicant interface state: ready -> inactive
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): supplicant interface state: ready -> inactive
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> WiFi now disabled by radio killswitch
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> WiFi now disabled by radio killswitch
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> (eth1): device state change: disconnected -> unavailable (reason 'none') [30 20 0]
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> (eth1): deactivating device (reason 'none') [0]
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): device state change: disconnected -> unavailable (reason 'none') [30 20 0]
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): deactivating device (reason 'none') [0]
Jan  6 23:30:34 laptop-hl NetworkManager[752]: NetworkManager[752]: <info> (eth1): taking down device.
Jan  6 23:30:34 laptop-hl NetworkManager[752]: <info> (eth1): taking down device.

Interestingly, connecting with wicd works. So I guess NetworkManager itself is the problem.

Does these informations help in any way and has anybody an idea whats wrong here?

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-01-06 17:20:08 -0500

I was going to mention that from time to time with various wireless cards wicd will work and NM will not.

I would suggest you file a bug report against NM.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-06 16:46:58 -0500

Seen: 2,234 times

Last updated: Jan 06 '12