Windows 7 won't boot after Dualboot-Install of Fedora 23

asked 2015-11-17 14:17:12 +0000

falk87 gravatar image

Hi everyone,

I have problems installing a dualboot with Windows 7Pro+SP1 and Fedora23 on a Lenovo W541.

What happened until now.

First try: BIOS Setup untouched (Boot: both, legacy first) Windows7 Pro+SP1 (Lenovo OEM Version, Rescue and Recovery) installed, with GPT-Partition. Works fine. Used Fedora23 Live-DVD, to make Windows7-Partition smaller and make room for Fedora; installed Fedora. Grub appears, Fedora23 works fine, Windows failed to start (BCD Error 0xc0000225). Only Lenovo Recovery Discs at hand -> Won't work as System Repair Disc -> Reinstalled Windows7, works fine.

Second try: Used Windows tools to burn a repair disc, make partition C:/ 300GB smaller and create a 200Gb Partition X:/ (as Data/Exchange-Partition for Windows7 and Fedora23). 100GB left unused -> installed Fedora23. Same problem: Grub appears, Fedora23 boots fine, Windows7 doesn't (still BCD Error 0xc0000225). The System Repair disc doesn't boot (I forgot to note what it said). Tried a clean Windows 7-DVD, got to the repair options (after wildly switching between UEFI/Legacy/Both-Boot-options), repeated the automatic repair options a few times, bootrec/fixmbr (successful. I just realised afterwards that might be wrong, having a gpt-partition-system), bootrec/fixboot, bootrec/rebuildbcd -> no windows installations found (although diskpart / list disk recognized the Windows-Volume). Restart: Grub doesn't appear. Only a message like: No operating System found.

And that brings us to third try and main question: Resetted BIOS settings to Standard. Changed Boot-option to: both, UEFI first. Currently reinstalling Windows 7 Pro+SP1, GPT-partition style, with Lenovo Recovery DVDs.

You certainly understood that I'm rather unfamiliar with these matters, so my question results in being a little vague: How should I proceed to have this dualboot working?

I'd be glad and thankful for every help!

Greetings Falk

edit retag flag offensive close merge delete

Comments

1

My guess is you are breaking windows by disabling uefi boot. but really this is IMO a question about Windows and not so much about Fedora.

bodhi.zazen ( 2015-11-17 17:08:41 +0000 )edit
1

stick to UEFI only if you want to boot GPT paritions.

kimbn ( 2015-11-17 19:17:46 +0000 )edit

Sorry, I was just looking for new answers and didn't see your comments. Thanks for the replies!

@bodhi.zazen I tried various bios-settings, but none of them worked. I let Windows resize it's own partition and it boots. That's why I thought the "BCD-error" must have something to do with GRUB or being a basic boot/mbr/efi-whatever-question...

@kimbn: Windows is now installed with gpt-partition-mode. During install bios was set to both (uefi first), but now it boots also with uefi-only. There was another boot-option which I changed from "Quick" to "Diagnostics". I'll try again.

falk87 ( 2015-11-18 08:37:00 +0000 )edit
1

I have a working dualboot now! Yeah! In summary this is what got it working: - Installing Windows7 with bios set to both(uefi first) - Making Windows Partition smaller with Windows tool - Set boot to UEFI only and changed from "quick" to "diagnostic" boot - Install Fedora (automatic partition) - both OSs work - Set boot mode to "quick" again, everything still works.

falk87 ( 2015-11-18 10:55:15 +0000 )edit