English
Ask Your Question
1

Screen tearing and low FPS with Intel HD 4400

asked 2015-12-04 07:28:23 +0000

Provash Shoumma gravatar image

updated 2015-12-04 21:28:51 +0000

Hi, I'm a newbie to Fedora. I'm currently using Fedora 23. The problem is, I have a wired screen tearing issue. If I move around Nautilus, only when it is on the top half of the screen, it get some tearing. That's true for every window.

Also I'm facing trouble of low FPS. When I play 1080p videos on Youtube, or a blueray movie on Video, the framerate become very low.

Is there any work around for the issues? I'm not much concerned with screen tearing, but I'm definitely not enjoying videos. Any help would be very much appreciated.

  • I'm using Gnome 3.18
  • I'm on Dell Inspiron 14 (3442). Hardware detail (lspci output) :

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-04 15:38:24 +0000

mithrial gravatar image

The tearing issue dissappeared in my case after creating a file /etc/X11/xorg.conf.d/20-intel.confwith the content:

# /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "sna"
    Option      "TearFree"    "true"
EndSection
edit flag offensive delete link more

Comments

This works! It stops the tearing issue. But it increase the frame drops. Any suggestion?

Provash Shoumma ( 2015-12-04 21:26:30 +0000 )edit

No, I'm sorry. I only copied the snippet myself from somewhere years ago.

mithrial ( 2015-12-04 23:52:12 +0000 )edit

I'm having the exact same problem. I'm having a lot of screen tearing when moving windows around and when watching videos. Basically the tearing happens whenever anything moves on the screen. When I set tearfree to true, the tearing disappears but then something weird happens. Whenever I'd move a window, the cursor moves first and then the window follows a bit later. My hardware is VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

Asad Moosvi ( 2015-12-07 09:35:47 +0000 )edit

Have you tried the line Option "AccelMethod" "sna"?

mithrial ( 2015-12-08 14:46:24 +0000 )edit

That's the default acceleration method. It's already set. I've also tried glamor but the tearing also happens when that's set.

Asad Moosvi ( 2015-12-08 14:53:03 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2015-12-04 07:28:23 +0000

Seen: 1,214 times

Last updated: Dec 04 '15