Ask Your Question
0

How to install nVidia proprietary on Notebook with Optimus ready?

asked 2015-12-04 11:13:41 -0600

Helcio Macedo gravatar image

Hey all! o/

I have a DELL Latitude 3440 and with it, the tecnology nVidia Optimus who will use 2 VGAs to work.

My lspci show this information: VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

so.. I want to install the nVidia Driver to work better on games and with the Optimus technology

I tried to do it: http://www.if-not-true-then-false.com... but i break my xserver always when i try.

Anyone can help me?? If possible, with a Step-by-Step to do it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-04 12:31:19 -0600

Fabash gravatar image

updated 2015-12-05 15:08:51 -0600

Hi

What do you mean by break Xserver? Do you get a GDM error?

In my case, I had to install bumblebee because my card had also optimus technology and it works great.

EDIT: add the instructions I used

Here are the commands I used, following the link I've given in my previous comment ( https://fedoraproject.org/wiki/Bumblebee ), assuming you are on fedora 23 also. I used close source driver (official from Nvidia), with a managed version.

Hope to trace everything...

Add bumblebee repo: (depending on what release you are on)

$ sudo dnf -y --nogpgcheck install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee/fedora23/noarch/bumblebee-release-1.2-1.noarch.rpm

Managed NVidia repo: (depending on what release you are on)

$ sudo dnf -y --nogpgcheck install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee-nonfree/fedora23/noarch/bumblebee-nonfree-release-1.2-1.noarch.rpm

*Multilib on a 64 bit install fedora 22+: *

$ sudo dnf install bumblebee-nvidia bbswitch-dkms VirtualGL.x86_64 VirtualGL.i686 primus.x86_64 primus.i686 kernel-devel

Then, you case use optimus command to run several tests:

optimus Syntax: $ optirun [options] application [application-parameters] $ optirun wine application.exe

Ex:

$ optirun glxgears
$ optirun -b none nvidia-settings -c :8

you could check that while the application is run via optimus, the nvidia driver is loaded:

$ lsmod | grep nvidia
nvidia               8642560  41
drm                   335872  13 i915,drm_kms_helper,nvidia
edit flag offensive delete link more

Comments

Which tutorial you follows? any links

robbnesp gravatar imagerobbnesp ( 2015-12-04 21:33:34 -0600 )edit

Hi. I followed this link: link text. I used the closed source drivers, with managed version. Hope this helps.

Fabash gravatar imageFabash ( 2015-12-05 14:55:48 -0600 )edit

All installation its done. But optirun returns this message: Do you know something about it?

$ **optirun glxgears**
[ 4798.481509] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

[ 4798.481613] [ERROR]Aborting because fallback start is disabled.
Helcio Macedo gravatar imageHelcio Macedo ( 2015-12-07 05:39:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-12-04 11:13:41 -0600

Seen: 630 times

Last updated: Dec 05 '15