English
Ask Your Question
1

How to configure remote desktop in Fedora 16 XFCE?

asked 2011-12-17 21:53:58 +0000

Penultimate gravatar image

updated 2011-12-17 21:56:06 +0000

I'm trying to follow the guide here to set up Remote Desktop on a Fedora system, but I'm running into a problem. I installed the vino package, but I'm stuck on this step

The next step in setting up remote desktop access is to activate it and define some 
basic security settings. These settings are configured in the Remote Desktop 
Preferences dialog. To access this dialog, open the desktop System menu and select 
Preferences followed by Remote Desktop.

I'm having trouble finding the Remote Desktop Preferences dialog. I've checked in Settings, Administrations, and System in the Applications Menu, and Remote Desktop is nowhere to be found. Is there a package I need to install in order to configure Remote Desktop?

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2012-03-08 16:13:40 +0000

ips gravatar image

Before running vino-preferences to enable desktop sharing, you'll need to start up vino-server:

$ /usr/libexec/vino-server

To automatically start vino-server every time you login to XFCE, go to "Application Menu > Settings > Session and Startup > Application Autostart" and add an application entry for /usr/libexec/vino-server.

edit flag offensive delete link more
0

answered 2013-08-29 16:39:49 +0000

Hallo,

i tried different vncservers, but i have still trouble that F16 is unrichable from WinXP and MacOS. Using vino-server I am receiving following message after start:

(vino-server:3283): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed

And connecting from Mac using Screen Sharing" gives following result:

"Connection failed to “tomas's remote desktop on dsunb02”."

"Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. "

edit flag offensive delete link more
0

answered 2011-12-19 20:54:33 +0000

mooninite gravatar image

The guide you linked to is for the Gnome Desktop Environment. The Remote Desktop preferences shortcut is visible under Gnome only. Vino may work for you under XFCE, but I have not used it under XFCE so I cannot say for certain.

You can access the preferences window in XFCE by running the command through a terminal or through the Run prompt.

$ vino-preferences

You may also have to place a .desktop file for vino into the ~/.config/autostart directory as XFCE may not start it for you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2011-12-17 21:53:58 +0000

Seen: 19,053 times

Last updated: Aug 29 '13