Ask Your Question

Screen tearing Fedora 23 GTX 970

asked 2015-12-19 13:16:14 -0500

miguel-sensacion gravatar image

I have a Intel 4690k | GTX 970 and the Nvidia 358.16 drivers. I get bad screen tearing while scrolling and moving windows

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-12-06 10:00:00 -0500

workman729 gravatar image

Well, i think first answer not usefull.

if you used nvidia gpu, it can be helpful this extension gnome-shell-extension-disable-unredirect.

Just add gnome version of meatadata.jason.

And intel gpu is add the tear free by xorg.conf.

edit flag offensive delete link more

answered 2015-12-19 18:54:50 -0500

Hello there, I had the same issue even when I try to maximize windows. I fixed it doing the next:

  • Open the file: /etc/default/grub
  • Find the variable: GRUB_CMDLINE_LINUX
  • Add into the value: i915.enable_ips=0

This is for example mine:

GRUB_CMDLINE_LINUX="i915.enable_ips=0 rhgb quiet"
  • Re-config Grub:

Choose depending your system

For EFI: sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

No EFI: sudo grub2-mkconfig -o /boot/grub2/grub.cfg
  • Restart your computer and try it.

I'm not and expert and I'm not sure if it works for everybody but hope It helps as much people as possible.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-12-19 13:16:14 -0500

Seen: 594 times

Last updated: Dec 06 '17