Ask Your Question
1

When I log in with GDM, it spawns another Xorg

asked 2016-01-06 23:51:12 -0500

subpop gravatar image

When I log in with GDM (running on vt1), what actually happens is a second Xorg session is spawned on a random vt (vt2, vt3, somtimes vt7). My GNOME session launches on that second Xorg. I only noticed this because the instance of gnome-shell that runs on gdm seems to have a leak of some sort and was consuming over 1 GB of memory. I think started jumping to other VTs and found GDM running on vt1. Why does GDM continue to run on another virtual terminal? Can I disable this somehow?

I've disabled Wayland in /etc/gdm/custom.conf, and am using the nvidia proprietary drivers.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-17 15:58:46 -0500

tfolger gravatar image

Same here, trying to figure this out.

$ ps aux | grep "[X]org vt"
root      2868  0.0  0.1 282848 62852 tty1     Sl+  May16   0:10 /usr/libexec/Xorg vt1 -displayfd 3 -auth /run/user/42/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
root      4496  2.3  1.4 820196 468408 tty2    Sl+  May16  32:47 /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3

# cat /etc/passwd | grep '1000\|42'
gdm:x:42:42::/var/lib/gdm:/sbin/nologin
muser:x:1000:1001:Main User:/home/muser:/bin/bash

OK, here's the answer: https://bugzilla.gnome.org/show_bug.c...

In summary: "working as designed" :(

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-06 23:51:12 -0500

Seen: 396 times

Last updated: May 17 '17