Ask Your Question
2

Fedora 23 Workstation Installation - Harddisk not available/visible

asked 2016-01-23 15:44:00 -0500

nadja gravatar image

updated 2016-01-24 17:25:57 -0500

mether gravatar image

Hey there :-)

When I try to install the Fedora 23 Workstation on my laptop, the main partition isn't available as an option. Only the USB drive, where the Fedora Live Workstation image is written on, is shown. And I'd like to get rid of Windows 10, which I upgraded to on my Windows 7 HP laptop. I've got a HP Envy 6 Ultrabook with an Intel Processor and a 64bit system, if this is any helpful information. :-)

I followed the installation guide ( https://docs.fedoraproject.org/en-US/... ), downloaded the live image (Fedora-Live-Workstation-x86_64-23-10.iso), verified the image by comparing it with the checksum file, which is available for download ( https://docs.fedoraproject.org/en-US/... ), used Rawrite32 to write the image onto a USB stick, pressed ESC to get boot options, chose the USB stick and started the installation process.

But when I'm asked to choose the installation destination, the hard drive with my Windows 10 on it isn't shown. The only option is the USB stick. So I get stuck at this point. ( https://docs.fedoraproject.org/en-US/... )

Probably I have to add, that it doesn't automatically boot from the USB stick, even though I've chosen it as the first option in the HP bios. I have to press ESC, which gives me the possibility to enter the bios or boot options. The boot options show the USB stick with the Fedora image, which I can choose and start the Fedora Live Workstation.

I would really appreciate, if someone could help me.

Thanks and best wishes, Nadja

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
1

answered 2016-04-22 09:28:23 -0500

blnt gravatar image

I had the exact same problem when installing Fedora 23 but on another machine (Dell XPS). The solution was to disable 'Raid On' mode for SATA ports in the Bios Setup (in my case to AHCI mode). Maybe you have some similar options on your machine?

Note that after changing the SATA mode you will probably not be able to boot into a system that was installed before.

edit flag offensive delete link more
0

answered 2016-01-23 16:51:46 -0500

paulojmlopes gravatar image

My guess is Secure Boot is enable on the BIOS.

edit flag offensive delete link more

Comments

Thanks for your answer, paulojmlopes. Secure Boot is disabled.

My bios looks quite the same as the one under "Using Secure Boot on newer notebook computers with Windows 8 and Windows 8.1" http://support.hp.com/us-en/document/... Settings are different though.

I changed UEFI and Legacy boot order to: - USB Diskette on Key/USB Hard Disk - USB CD/DVD ROM Drive - OS boot Manager / - Notebook Hard Drive - ! Network Adapter

The stick is a USB 2.0, and I think, the slot is an USB 3.0.

nadja gravatar imagenadja ( 2016-01-23 18:13:58 -0500 )edit

If the disk isn't shown you also should verify that the disk controller in the BIOS i set to AHCI.

thomaswood gravatar imagethomaswood ( 2016-01-24 07:08:13 -0500 )edit

Hey thomaswood, thanks for your reply! I can't find any option like that - neither disk controller nor AHCI as an option. There aren't many options at all for my taste in my BIOS. Any more tips?

nadja gravatar imagenadja ( 2016-01-24 12:02:52 -0500 )edit

When you boot into the Live Image of FC23, open a terminal and check if the disk is recognized at all by executing sudo fdisk -l and dmesg output would also be helpful.

thomaswood gravatar imagethomaswood ( 2016-01-25 00:48:46 -0500 )edit

I'm not quite sure, whether all the text is being posted. Is there any possibility to post such huge amounts of text?

nadja gravatar imagenadja ( 2016-01-25 13:50:01 -0500 )edit
0

answered 2016-01-25 13:47:26 -0500

nadja gravatar image

updated 2016-01-31 15:20:26 -0500

Ok, I've given it up. Thanks everyone for your help! It was worth a try.

edit flag offensive delete link more
0

answered 2016-02-14 16:44:29 -0500

technog1 gravatar image

updated 2016-02-14 17:31:51 -0500

(Edited for better formatting)

Najda, have you gotten anywhere ?

I am getting the same error with my desktop running windows 10, dell i7, 16GB.

I have enabled legacy mode

disabled secure boot

I shut down windows via menu - no hibernation.

I also get an error msg that scrolls by too fast but from what i can capture "...pcieport.type Physical Layer.id=Receiver ID"

This is crazy !

I never had this type of problem during installs of fedora before ! its either the newer bioses (uefi) or windows 10 ?? probably uefi. But cannot tell

edit flag offensive delete link more
0

answered 2016-01-25 15:08:30 -0500

Paolo gravatar image

Hi Nadja, have you actually turned off windows? I mean, when you use shutdown option you are not really shutting down your OS but doing an hibernation. So that your hard drive is still mounted and installation wizard doesn't see it. You should use shutdown /s from a command prompt (search for cmd in windows search bar).

edit flag offensive delete link more

Comments

Hi Paolo, thanks for your help. Yes, I usually did shutdown. I just did the way, you said. Worked fine to shutdown. I restarted the laptop, opened boot options, chose the stick with Fedora on it and tried the installation again. Still, there is no drive available.

I might add, that I created a new stick with help of LiveUSB Creator, as decribed in the Fedora installation guide. It only allowed FAT32 to be created to. Now not even the memory stick is showed as an option to install to. The previous stick was formatted to NTFS and available as an option to install Fedora to.

nadja gravatar imagenadja ( 2016-01-25 15:26:10 -0500 )edit

Is it possible, that my antivirus software has something to do with it? Or do I get paranoid? :-) I've got Bitdefender and HitmanPro.Alert installed.

nadja gravatar imagenadja ( 2016-01-25 15:30:23 -0500 )edit

It's not my security tools. Deinstalled them, tried installation of Fedora again. No success. :-(

nadja gravatar imagenadja ( 2016-01-25 16:42:19 -0500 )edit
0

answered 2016-01-26 12:11:39 -0500

ua gravatar image

dont know if this helps.but i had to disable fastboot in windows 10 power settings and in bios before fedora 23 usb installer worked on my pc with uefi bios

edit flag offensive delete link more

Comments

Unfortunately that didn't work, but thanks anyway! I disabled fastboot, but the SSD is still not available.

Did I get this right, that the "sudo fdisk -l" shows my solid state drive? I mean, these 465GB are obviously, what I'm looking for in the installation process.

nadja gravatar imagenadja ( 2016-01-26 13:53:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-23 15:44:00 -0500

Seen: 4,884 times

Last updated: Feb 14 '16