Ask Your Question

Proper disabling of WiFi power management

asked 2011-11-17 14:12:24 -0500

darence gravatar image

updated 2011-11-17 14:15:55 -0500


I have an Acer Aspire One and the power management for WiFi connections is on by default, causing really bad connection quality. I know how to turn this off:

sudo iwconfig wlan0 power off

To make it permanent, as a dirty hack I can just add this line to /etc/rc.local, for instance. However, I would like to know what the proper way to change this setting is. I tried changing various settings in /etc/sysconfig/network-scripts but no luck.

Can someone help?

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted

answered 2017-09-21 15:58:22 -0500

jenovanm gravatar image

Disabling Power Management just worked yet again. Surface Pro 3/ Fedora 26. Thanks for the info.

edit flag offensive delete link more

answered 2017-01-02 13:11:10 -0500

deajan gravatar image

updated 2017-01-02 13:27:41 -0500

Great answer in ! Here are my two cent that make it work regardless of the interface number or names:

ifaces=$(iwconfig 2> /dev/null | grep "802.11" | awk '{print $1})
for iface in $ifaces; do
    if [ "${IF}" = "$iface" ] && [ "${STATUS}" = "up" ]; then
        iwconfig ${iface} power off
        logger "${iface}: turning off powersave mode to prevent constant reconnections"
edit flag offensive delete link more

answered 2013-04-10 11:57:04 -0500

Flying4Fun gravatar image

updated 2013-04-10 11:58:31 -0500

I know it's a little late, but hope it helps others that have the same question.

Create a NetworkManager script i.e. /etc/NetworkManager/dispatcher.d/02-wlan-powersave-off

if [ "${IF}" = "wlan0" ] && [ "${STATUS}" = "up" ]; then
   iwconfig ${IF} power off
   logger "${IF}: turning off powersave mode to prevent constant reconnections"

Don't forget to chmod 755 /etc/NetworkManager/dispatcher.d/02-wlan-powersave-off

Restart NetworkManager (using Fedora with systemd):

systemctl restart NetworkManager.service
edit flag offensive delete link more


This is a great way to do this. However, your script as it is did not work in my Raspberry Pi running Pidora (Fedora 20 remix). The problem, which is probably also common to other environments, is that the PATH for the dispatcher scripts does not by default contain /sbin.

To fix: I simply replaced "iwconfig" with "/sbin/iwconfig" and it worked great.

Kayvan gravatar imageKayvan ( 2015-01-01 22:09:09 -0500 )edit

answered 2012-10-18 23:28:14 -0500

Based on this Ubuntu based solution I did the following.

sudo vi /etc/pm/power.d/wireless

Then paste the following and save the file

/usr/sbin/iwconfig wlan0 power off

Finally, make it executable

sudo chmod +x /etc/pm/power.d/wireless

This should make power management be off on reboot.

edit flag offensive delete link more

answered 2011-11-18 07:48:31 -0500

ritz gravatar image

One option would be to add this to /etc/rc.d/rc.local, and enabling +x on this file.

$ vim /etc/rc.d/rc.local $ chmod +x /etc/rc.d/rc.local

Personally, this needs to be fixed in kernel, or NetworkManager code.

edit flag offensive delete link more

answered 2011-11-17 14:45:53 -0500

SoumyaC gravatar image

updated 2011-11-17 14:46:07 -0500

Follow the below steps -

# su -
# vi /var/lib/NetworkManager/NetworkManager.state

In the file you will see the below contents -


Change the value of WirelessEnabled=false

Restart the NetworkManager

# service NetworkManager restart

This should work !!

edit flag offensive delete link more


Did the solution work and solved your problem ?

SoumyaC gravatar imageSoumyaC ( 2011-11-25 12:09:22 -0500 )edit

I believe the OP wanted to disable power management NOT disable wireless.

Flying4Fun gravatar imageFlying4Fun ( 2013-04-10 12:01:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2011-11-17 14:12:24 -0500

Seen: 14,769 times

Last updated: Jan 02 '17