English
Ask Your Question
0

How to enable touchpad click at Fedora 23 (Asus K52JC)?

asked 2016-02-01 10:33:03 +0000

ranek gravatar image

updated 2016-02-02 03:54:26 +0000

mether gravatar image

Hi! :) I'm trying to enable touchpad click in Fedora 23 on Asus K52JC, but it doesn't work. Coul'd you help? :) I mean I know that problem isn't new, but I heard that Synaptic drivers aren't longer supported. Is that true? I mean, that's not workin':

cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

Section  "InputClass"
Identifier  "touchpad catchall"
Driver  "synaptics"
MatchIsTouchpad  "on"

####################################
## The lines that you need to add ##
# Enable left mouse button by tapping
Option  "TapButton1"  "1"
# Enable vertical scrolling
Option  "VertEdgeScroll"  "1"
# Enable right mouse button by tapping lower right corner
Option "RBCornerButton" "3"
####################################

MatchDevicePath  "/dev/input/event*"
EndSection

from: https://fedoraproject.org/wiki/How_to...

neither this:

cat /etc/X11/xorg.conf.d/01-touchpad.conf 

Section "InputClass"
    Identifier  "tap-by-default and other custom settings"
    MatchIsTouchpad "on"
    Option "TapButton1" "1"
    Option "TapButton2" "1"
    Option "TapButton3" "1"
    Option "VertEdgeScroll" "1"
    Option "HorizEdgeScroll" "1"
    Option "VertTwoFingerScroll" "1"
    Option "HorizTwoFingerScroll" "1"
EndSection

from: https://ask.fedoraproject.org/en/ques...

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-02-01 11:24:01 +0000

ranek gravatar image

updated 2016-02-01 11:50:56 +0000

All right. I just found the solution. ;) :D :D

Just in Settings -> Mouse & Touchpad -> Check to: "Tap to Click". Piece of cake. Damn. 8-)

PS: Anyway works at XFCE ;)

Thanks a lot. :)

edit flag offensive delete link more

Comments

You're the man! :D Simple as water. Thanks! This really works ;)

mephisto ( 2016-07-31 16:40:28 +0000 )edit
1

answered 2016-02-04 05:54:04 +0000

whot gravatar image

The default touchpad driver in F23 is xorg-x11-drv-libinput which has different xorg.conf options. look up man libinput man, the option to enable tapping is "Option "Tapping" "on""

That only sets the startup default, desktop environments like gnome and XFCE have adjusted to libinput now and probably overwrite the startup defaults. In that case you'll need to find the DE-specific config tool option - which you already did :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2016-02-01 10:31:05 +0000

Seen: 894 times

Last updated: Feb 04 '16