Ask Your Question

Full RAM not detected (1.6GB / 2GB) (X86_64)

asked 2016-02-06 09:47:20 -0500

Fabash gravatar image

updated 2016-02-06 09:48:15 -0500


I've installed Fedora 23 on an old EeePC laptop on which 2GB of RAM is installed on one bank.

Linux does not detect the whole amount of memory. It's not related to PAE because I've got an x86-64 kernel. Only 1,6 GB of RAM is detected.

$ uname -a
Linux neptune 4.3.4-300.fc23.x86_64 #1 SMP Mon Jan 25 13:39:23 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ free -h
              total        used        free      shared  buff/cache   available
Mem:           1,6G        920M        215M        150M        469M        472M
Swap:          1,5G         60M        1,5G

$ cat /proc/meminfo 
MemTotal:        1643664 kB
MemFree:          220084 kB
MemAvailable:     483556 kB
Buffers:           22216 kB
Cached:           379392 kB
SwapCached:         1416 kB
Active:           615028 kB
Inactive:         573284 kB
Active(anon):     474636 kB
Inactive(anon):   466356 kB
Active(file):     140392 kB
Inactive(file):   106928 kB
Unevictable:          36 kB
Mlocked:              36 kB
SwapTotal:       1605628 kB
SwapFree:        1543868 kB
Dirty:                88 kB
Writeback:             0 kB
AnonPages:        785604 kB
Mapped:           323332 kB
Shmem:            154288 kB
Slab:              79684 kB
SReclaimable:      34944 kB
SUnreclaim:        44740 kB
KernelStack:        8272 kB
PageTables:        38892 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     2427460 kB
Committed_AS:    4694444 kB
VmallocTotal:   34359738367 kB
VmallocUsed:      296464 kB
VmallocChunk:   34358947836 kB
HardwareCorrupted:     0 kB
AnonHugePages:         0 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
DirectMap4k:      339828 kB
DirectMap2M:     1345536 kB
DirectMap1G:           0 kB

Would you have any clue of what's going ? Thanks

edit retag flag offensive close merge delete



This could be due to devices, like graphics card with shared memory to reserve space from RAM. A lspci -v | less and then search for Memory should give you hints.

thomaswood gravatar imagethomaswood ( 2016-02-06 10:25:15 -0500 )edit

Have you double checked in your BIOS/UEFI interface to ensure that the motherboard firmware is at least detecting the proper amount of RAM?

bitwiseoperator gravatar imagebitwiseoperator ( 2016-02-06 11:19:25 -0500 )edit

Unless you're planning to add more RAM, you don't need an X64 system. Have you tried booting a LiveUSB with a 32 bit system and checking what it reports? If it also only finds 1.6 GB, it may be a hardware issue, although I'll admit that it's unlikely.

sideburns gravatar imagesideburns ( 2016-02-06 18:10:01 -0500 )edit

Find Shared video Memory and/or RAM in BIOS and you have you answer.

paulojmlopes gravatar imagepaulojmlopes ( 2016-02-07 04:51:41 -0500 )edit

Thanks a lot for your replies.

@thomaswood : That is a good clue ! I got around 256MB for the VGA card itself ! @bitwiseoperator: yes, it's one of the firt thing I've checked and it's 2GB. A memtest runs at boot only detect 1.6GB.

@sideburns: thanks. I didn't have time/possibility to do it but I will.

@paulojmlopes: unfortunately, my BIOS seems limited. I don't have this option.

So, it's certainly due to shared memory with the graphics card. I will compare with my other laptop or other LInux PC.

Fabash gravatar imageFabash ( 2016-02-09 16:05:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-07 21:15:12 -0500

ed209 gravatar image

Of course linux detects all ram. You are using something less than 512MB for your video card as shared memory. So 2GB-0.4GB = 1.6GB, as correctly stated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-02-06 09:47:20 -0500

Seen: 557 times

Last updated: Feb 06 '16