English
Ask Your Question
2

How do I change my monitor's resolution?

asked 2012-01-25 20:08:11 +0000

David_LeBlanc gravatar image

updated 2012-02-02 08:39:21 +0000

I have problems to change resolution. I tryed via editing the file /etc/default/grub and adding this line GRUB_GFXMODE="1280x1024x32" But it doesn't change.The KrandTry crashes after it stars to load, i didn't found the Xorg since my fedora is Verne, and some of the main solutions i found are quite old. Note: My monitor supports that resolution.

xrandr output is:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096 VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.0* 800x600 60.3 56.2
848x480 60.0
640x480 59.9

edit retag flag offensive close delete

Comments

What graphics card do you have ?

bodhi.zazen ( 2012-01-25 21:43:48 +0000 )edit

Are you trying to change the text console resolution or the X screen resolution?

mooninite ( 2012-01-25 22:24:05 +0000 )edit

I have an integred one (Intel - Express Chipset Family). mooninite, i'm trying to change the X screen resolution. I heard of a autostart file with a script to change it but i don't know how to do it.

David_LeBlanc ( 2012-01-26 02:52:19 +0000 )edit

What is the output of xrandr?

skytux ( 2012-01-26 12:11:41 +0000 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2012-01-26 17:13:52 +0000

updated 2012-02-01 07:34:06 +0000

Create a file in /etc/X11/xorg.conf.d/

40-monitor.conf

Section "Monitor"
  Identifier  "VGA1"
  Option      "PreferredMode" "1280x1024"
EndSection

Restart your X system.

If it doesn't work try creating the next two files in the same path, and restarting again:

30-graphic.conf

Section "Device"
    Identifier      "Intel Integrated"
    Driver          "intel"
EndSection

50-screen.conf

Section "Screen"
    Identifier      "Default Screen"
    DefaultDepth  24
    SubSection "Display"
            Depth          24
            Modes         "1280x1024"  "1024x768"   "640x480"
    EndSubSection
EndSection

Undetected resolution

If your monitor supports a resolution, but it's not published correctly, you can add it manually.

Look at the following link (section Adding undetected resolution) https://wiki.archlinux.org/index.php/Xrandr

Once you get it working make the changes persistent in a file inside /etc/X11/xorg.conf.d/


Persistent new modeline

After you added the new resolution for your monitor, you must save it. Execute:

cvt 1280 1024

You will get something as:

1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz

Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

The interesting bit is the modeline. Copy it and paste in a file: /etc/X11/xorg.conf.d/40-monitor.conf

Section "Monitor"
  Identifier  "VGA1"
  Modeline    "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
  Option      "PreferredMode" "1280x1024_60.00"
EndSection

Restart X11 and there you go...


If the above doesn't make persistent your new configuration try adding the xrandr magic in a file read by xorg, by example gdm or kdm configuration:

gdm

edit /etc/gdm/Init/default

add the xrandr commands after

PATH=/usr/bin:$PATH

OLD_IFS=$IFS

xrandr --newmode ...
xrandr --addmode YOURMONITOR YOURNEWMODE
xrandr --output YOURMONITOR --mode NEWMODE

kdm

You can add the xrandr lines in /etc/kde/kdm/Xsetup or in /etc/kde/kdm/Xsession but with full path:

/usr/bin/xrandr --newmode ...
/usr/bin/xrandr --addmode YOURMONITOR YOURNEWMODE
/usr/bin/xrandr --output YOURMONITOR --mode NEWMODE

If someone knows why saving the modeline in the xorg config doesn't get it applied, please let me know, I'm pretty curious (and the xorg webpage seems down at the moment)...

edit flag offensive delete publish link more

Comments

I tried the first solution and now my fedora couldn't load. I erase that file and i'm where i started but with a black line on the right corner. The second one didn't work out.

David_LeBlanc ( 2012-01-27 02:03:20 +0000 )edit
1

then i would say that your monitor doesn't support that resolution. Can you try to paste the "xrandr" output? If your are using kde you can change your screen resolution inside the desktop: System Settings -> Screen and Monitor

ZenDark ( 2012-01-27 06:37:38 +0000 )edit

The screen do suport it, but i don't know why the resolution still the same (1024x768) and now my monitor doesn't resize it to fill the screen (like before) leaving a black line. The maximum resolution shown is 1024x768.

David_LeBlanc ( 2012-01-27 11:44:19 +0000 )edit

Your monitor is not reporting it can support that resolution. You can either go through a bunch of complicated xorg.conf settings to manually override EDID detection, file a X.org server bug, or buy a monitor that works correctly.

mooninite ( 2012-01-27 17:15:59 +0000 )edit

I already said that the monitor support that resolution, i touch the menú of the monitor and it says "for a better perfomance is recomended 1280x1024" In fact that was the resolution that i used in window$. So please, i insist, the monitor suppor it.

David_LeBlanc ( 2012-01-27 17:53:33 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2012-01-25 20:08:11 +0000

Seen: 44,523 times

Last updated: Feb 02 '12