Ask Your Question
1

kmod-VirtualBox conflict

asked 2016-02-21 06:11:14 -0600

kostaldavid8 gravatar image

updated 2016-04-05 10:46:52 -0600

sergiomb gravatar image

Hi, when I try to install VirtualBox kernel module package (kmod-VirtualBox), I've gon an error

package kmod-VirtualBox-5.0.14-1.fc23.x86_64 requires kmod-VirtualBox-4.2.3-300.fc23.x86_64 >= 5.0.14-1.fc23, but none of the providers can be installed.

Allow erasing does not work. Thanks for your help.

edit retag flag offensive close merge delete

Comments

did you ever get this issue resolved? I have same issue

willvest gravatar imagewillvest ( 2016-03-03 11:42:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-04-05 10:22:36 -0600

sergiomb gravatar image

updated 2016-04-05 10:40:58 -0600

http://rpmfusion.org/Howto/VirtualBox , since F22 we don't have pre-built kmods we need use akmods .

edit flag offensive delete link more
0

answered 2016-04-05 15:29:05 -0600

agreco gravatar image

check your kernerl version uname -r

try to remove virtual box end reboot the system

sudo dnf remove VirtualBox-5.0.x86_64 shutdown -r now

after the reboot try to reinstall VBox

sudo dnf install VirtualBox-5.0-5.0.6_103037_fedora22-1.x86_64 sudo /etc/init.d/vboxdrv setup

if this dosen't work

dnf remove kmod-VirtualBox-* dnf install akmod-VirtualBox kernel-devel akmods systemctl restart systemd-modules-load

A.G

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-02-21 06:11:14 -0600

Seen: 571 times

Last updated: Apr 05 '16