English
Ask Your Question
1

gnome-shell eats the entire CPU (99% usage).

asked 2016-02-23 20:17:05 +0000

jski3 gravatar image

I work for a company that has a boat load of (or train load of) Dell Latitudes x686 laptops (circa 2008). We're try to install Fedora 23 on them. When I upgraded (dnf update) from the kernel that comes with the 23-ISO (from 4.2.3-300.fc23.i686 to 4.3.5-300.fc23.i686) and log in, the machine is almost completely unresponsive. If I leave the machine alone the CPU usage goes to ~19% BUT if I try to move a teminal window (e.g.) the CPU usage immediately jumps to 99%.

I run "top" and the CPU % for the gnome-shell is about 99%. I've tried using "gnome-tweak-tool" to disable the extention "Background Logo" in the overview "Extentions". This does not work.

So currently I select the 4.2.3-300.fc23.i686 kernel when booting. This works. if you don't try adding an external monitor. Even then if a try to add an (additional) external monitor, the problem reoccurs immediately.

More info: root@localhost ~# lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Any suggestions?

---John

edit retag flag offensive close merge delete

Comments

1

Welcome to ask.fedora. From what you write, it looks like you've only installed Fedora on one test box. Is there any reason that you have to use Gnome, or is it just that Gnome is the default? You might want to experiment with KDE and/or Xfce and see if one of them has better performance for you now, instead of having to migrate everybody to a different DE later.

sideburns ( 2016-02-23 21:03:34 +0000 )edit

Or you could login to “GNOME Classic” by clicking the little gear on the login page (underneath the password entry field).

Aeyoun ( 2016-02-24 13:38:29 +0000 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2016-07-16 11:09:21 +0000

HugoH gravatar image

I've got the very same problem on my Lenovo Yoga 2 Pro (which has quite OK hardware). This means I am also stuck on the 4.2.3-300.fc23.x86_64 kernel, which fortunately doesn't make gnome-shell sluggish. For the record, not even an external screen on 4.2.3-300.fc23.x86_64 gives me sluggishness.

We're both on Intel hardware tough, but mine is slightly newer:

~$ lspci 
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Device 0a03 (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 8 Series Thermal (rev 04)
01:00.0 Network controller: Intel Corporation Wireless 7260 (rev bb)

So maybe somewhere in Intel's land of the kernel space we've got a degrade in recent kernels?

edit flag offensive delete link more
0

answered 2016-02-25 02:06:21 +0000

  1. Try a different laptop to rule out a bad video card.
  2. Try "GNOME Classic" as Aeyoun suggested to rule out possible problems with shell extensions.
  3. Take a look at the output of dmesg and/or "journalctl | tail " to see if there are any errors related to the video driver at the end.

Unfortunately, in my experience Gnome works better on newer hardware that what you have. Just running the plain desktop with no apps will require 1 GB of RAM. This is true of all 3 laptops I have. I suggest at least 4 GB of RAM and a machine capable of 64-bit (to be new enough and fast enough) if you want to have a good experience with Gnome.

That's not to say that you can't get it to work. But due to the age of the machine, it's less likely. I' m guessing that you're running into a video driver defect that's triggering bad behavior in the Gnome Shell or a defect in Gnome Shell that is only triggered by your video card. Filing a bug report against the video driver and/or Gnome Shell would be helpful.

For the age of the machine you're working with, I would echo Florian's recommendation to use Xfce instead. Gnome just isn't a good fit for your hardware. But, Xfce functions well on older machines. It can also be configured to look like Windows or Gnome if you dig into the preferences of all the GUI panels. LXDE is an option also, but personally I find the functionality and look to be too basic. Most people will be happier with Xfce I think.

edit flag offensive delete link more

Comments

I've got the very same problem on my Lenovo Yoga 2 Pro, which has quite OK hardware so I am also stuck on the 4.2.3-300.fc23.x86_64 kernel, which fortunately doesn't make gnome-shell sluggish. This isa software issue.

HugoH ( 2016-07-16 10:58:44 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2016-02-23 20:17:05 +0000

Seen: 326 times

Last updated: Jul 16 '16