Ask Your Question

VirtualBox Kernel driver not installed (rc=-1908)

asked 2016-02-28 20:37:47 -0500

si42 gravatar image

updated 2016-03-19 09:35:16 -0500

hhlp gravatar image

I have fedora 22 and trying to setup a machine on VirtualBox.

I have followed the post @

but when i run /etc/sysconfig/modules/VirtualBox.modules it says no such file or directory. I have tried to reboot the system and VBox still doesn't start. Please help i'm stuck on this for 2 weeks now and tried everything.


[root@new-host ko]# uname -r


[root@new-host ko]# dnf install kmod-VirtualBox-4.3.6-201.fc22.x86_64.x86_64

Last metadata expiration check performed 2:33:58 ago on Sun Feb 28 18:49:17 2016.

Package kmod-VirtualBox-4.3.6-201.fc22.x86_64-4.3.32-1.fc22.x86_64 is already installed, skipping.

Dependencies resolved.

Nothing to do.


[root@new-host ko]# /etc/sysconfig/modules/VirtualBox.modules

bash: /etc/sysconfig/modules/VirtualBox.modules: No such file or directory
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2016-02-28 21:06:31 -0500

sergiomb gravatar image

updated 2016-03-18 19:49:53 -0500

Please do:

dnf install VirtualBox kernel-devel-$(uname -r)  akmod-VirtualBox
systemctl restart systemd-modules-load.service
dmesg | grep -i vbox


[ 2870.556703] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
[ 2870.565213] vboxdrv: Found 2 processor cores
[ 2870.571315] vboxdrv: fAsync=0 offMin=0x1c2 offMax=0xa5f
[ 2870.671515] vboxdrv: TSC mode is Synchronous, tentative frequency 3000795689 Hz
[ 2870.671519] vboxdrv: Successfully loaded version 5.0.6_ (interface 0x00240000)
[ 2870.671946] VBoxNetFlt: Successfully started.
[ 2870.672227] VBoxNetAdp: Successfully started.

if you want try VirtualBox 5 you may enable my copr repo

dnf copr enable sergiomb/vboxfor23

To sign kernel modules to make work with secure boot, this 2 posts are a good reference , I haven't test my self:

or google for "virtualbox fedora secure boot" .

edit flag offensive delete link more


i tried everything u said and more. nothing seems to work. The problem is Secure Boot. If it is enabled virtualbox will not work no matter what. As soon as i disabled it works right away. SUPER annoyiing

si42 gravatar imagesi42 ( 2016-02-29 09:34:37 -0500 )edit

This worked for me. However I had to restart systemd-modules-load.service twice, not a big deal but though it should be noted.

ryan27996 gravatar imageryan27996 ( 2016-03-18 19:36:02 -0500 )edit

answered 2016-02-29 05:27:19 -0500

masteroman gravatar image

Those instructions are quite old. If you have rpmfusion repository enabled install Virtualbox from there:

dnf install VirtualBox.x86_64

and everything should work. If not you may try to follow this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-02-28 20:37:47 -0500

Seen: 1,735 times

Last updated: Mar 19 '16