English
Ask Your Question
4

set default entry in grub on fedora 18

asked 2013-02-06 13:52:18 +0000

Rahul Bhadana gravatar image

updated 2013-09-03 22:02:38 +0000

i am unable to set windows 8 as the default entry in grub 2 (Fedora 18)

i try following but nothing happen

1 - Setting default entry in http://fedoraproject.org/wiki/GRUB_2

2 - https://ask.fedoraproject.org/question/1900/how-can-i-change-default-operating-system-in-start

edit retag flag offensive close delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-06 16:42:43 +0000

kynde gravatar image

updated 2013-02-06 16:46:06 +0000

Edit that line in /etc/grub2/grub.cfg :

set default="0"

That 0 means first entry, 1 for second and so forth.

Notice that this does not survive grub2-mkconfig, and also notice that this is not the recommended method, but since you did link to the recommended and didn't get that to work, I feel it's ok to suggest this, because this does work.

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
1 follower

Stats

Asked: 2013-02-06 13:52:18 +0000

Seen: 3,133 times

Last updated: Sep 03 '13