English
Ask Your Question
0

How do I enable tap on my touchpad?

asked 2016-03-08 04:19:50 +0000

lohroc gravatar image

updated 2016-03-31 15:53:59 +0000

florian gravatar image

My left touchpad button doesn't work, I used to just tap the touchpad instead but that isn't enabled by default and there isn't any options for that on input devices(keyboard and mouse).

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-03-08 05:17:39 +0000

jtlinux gravatar image

updated 2016-03-31 13:21:13 +0000

You're using LXDE? Doesn't look like there's a GUI.

There are two ways:

1. xorg.conf

I think the best and most orthodox way is to follow these steps ( https://fedoraproject.org/wiki/How_to... ):

Copy the /usr/share/X11/xorg.conf.d/50-synaptics.conf file to /etc/X11/xorg.conf.d/

cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

Then, in your favourite text editor, modify this file as such:

Section  "InputClass"
Identifier  "touchpad catchall"
Driver  "synaptics"
MatchIsTouchpad  "on"

####################################
## The lines that you need to add ##
# Enable left mouse button by tapping
Option  "TapButton1"  "1"
# Enable vertical scrolling
Option  "VertEdgeScroll"  "1"
# Enable right mouse button by tapping lower right corner
Option "RBCornerButton" "3"
####################################

MatchDevicePath  "/dev/input/event*"
EndSection

For more information on tweaking xorg.conf.d files, please read the man page:

man xorg.conf

2. synclient

Alternatively, there's also a very easy way found here ( http://stevenrosenberg.net/blog/deskt... ):

synclient TapButton1=1

If you ever want to turn it off again, use:

synclient TapButton1=0

Let me know how it goes!

edit flag offensive delete link more

Comments

Yes, I'm using LXDE. I'll try these out.

lohroc ( 2016-03-08 10:47:02 +0000 )edit

note that these instructions won't work on a default install of F22 or later , we don't use the synaptics driver anymore and the libinput driver has slightly different options. I'll fix up the fedora wiki you posted to be up-to-date again

whot ( 2016-04-07 23:04:40 +0000 )edit
0

answered 2017-10-22 10:52:17 +0000

luissm gravatar image

This don't work anymore in fedora 26 LXDE!!!

In LXDE-spin, we don't have a way to configure the Touchpad, and the Touchpad click doesn't work.

The Fedora 26 don't have synaptics driver anymore.

How to enable Touchpad Click in LXDE Fedora 26?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2016-03-08 04:19:50 +0000

Seen: 1,924 times

Last updated: Mar 31 '16