Ask Your Question
0

Fedora 17 Connected to the net - but not finding pages.

asked 2012-08-25 09:04:51 -0600

joshswlms gravatar image

I recently switched from Ubuntu to Fedora because of its Gnome 3 friendliness, and due to DNS issues I was having. But now am having the same issues in Fedora with the internet. When connected to any network away from my home, being work, or a coffee shop everything works great. At my home though I get nothing. It is connected to the network, but when I go to a website the site is never found and Firefox just sits there searching. I am dual booting Windows 8 (that's how I am trying to solve this issue) and everything works fine. But I really love Linux and would hate to not be able to use it any longer.

I should also mention that I am using a Comcast highspeed internet modem/wifi router combo supplied by Comcast.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2012-08-26 00:39:50 -0600

ruturajv gravatar image

are you able to ping 8.8.8.8 ? $ ping 8.8.8.8

If you are probably your DNS setting is incorrect. Just Edit your Wired Network connections, Select IPv4 settings > change method to "Automatic (DHCP only) addresses only and set 8.8.8.8 as your primary DNS

edit flag offensive delete link more
0

answered 2013-04-04 09:45:22 -0600

joshswlms gravatar image

Just in case anyone every comes to this question and is having the same issue. The issue was the wireless router from Comcast. The router automatically resets and blocks DNS settings, even using OpenDNS. You will have to call Comcast have alert them to the issue and trade your wireless router/modem out for a up to date piece of equipment.

edit flag offensive delete link more
0

answered 2013-04-05 05:27:57 -0600

anurag gravatar image

updated 2013-04-05 05:29:02 -0600

Check cat /etc/resolve.conf

It will show the nameserver. If not showing the name server this must be a DNS issue.

Try creating a file vi /etc/sysconfig/network-scripts/ifcfg-

and put these lines

PEERDNS = yes

DEFROUTE = yes

Its a DNS related issue.

edit flag offensive delete link more
0

answered 2012-09-01 14:24:00 -0600

Akshay gravatar image

updated 2012-09-01 14:24:59 -0600

i recommend you to use open dns http://www.opendns.com/ , its free and you don't have to compromise with speed or you can directly change your primary or secondary dns to

208.67.222.222

208.67.220.220

but if you are not sure how to change then go to http://www.opendns.com/ create account and follow the steps to implement open dns

edit flag offensive delete link more

Comments

have you changed the dns in comcast router ??, please check if mtu is set to 1500 if not set to 1500 by "ifconfig etho mtu 1500"

Akshay gravatar imageAkshay ( 2012-09-05 08:12:16 -0600 )edit

it depends on which router you are using, manual dns config is available in all router, i suggest you to go to http://www.opendns.com, create account and follow the steps to configure open dns

Akshay gravatar imageAkshay ( 2012-09-10 06:51:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-25 09:04:51 -0600

Seen: 2,400 times

Last updated: Apr 05 '13