Ask Your Question

Libreoffice doesn't start through ssh -X any more

asked 2016-03-16 04:19:57 -0500


I'm connecting from a PC with Fedora 23 workstation 64 bits, to another PC with Fedora 23 workstation 64 bits, through ssh -X. I used to be able to launch libreoffice this way (launching "libreoffice" from the command line), but it doesn't work any longer: I see LibreOffice's logo, but nothing more. No error message appear. Evince, Nautilus, BlueFish, Firefox, Gimp and Inkscape start correctly. If I sit on the second computer, libreoffice works correctly.

Any idea?

edit retag flag offensive close merge delete



Are you using X or Wayland?

jmt gravatar imagejmt ( 2016-03-16 10:13:00 -0500 )edit

I don't know. The default one. gravatar ( 2016-03-25 02:05:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-03-16 10:45:39 -0500

hhlp gravatar image

updated 2016-03-16 10:47:54 -0500

If a LibreOffice window is open, it opens a window in the display of that process. Therefore one way would be to kill any running LibreOffice processes.

logging thru ssh :

ssh -x localhost -> this is a example

run this in terminal inside the ssh session :

ps aux | grep libreoffice

example :

hhlp 4889 0.0 0.9 782400 80432 ? Sl 10:53 0:01 /usr/lib64/libreoffice/program/soffice.bin

kill the process in ssh session if there are any :

kill -9 {process id from the command above}

example :

kill -9 4889

and then run :

DISPLAY=:0 libreoffice


edit flag offensive delete link more


Thank you very much, but it doesn't work:

$ DISPLAY=:0 libreoffice
No protocol specified
Failed to open display
No protocol specified
No protocol specified gravatar ( 2016-04-29 03:34:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-03-16 04:19:57 -0500

Seen: 416 times

Last updated: Mar 16 '16