Ask Your Question
0

How do I change the default terminal in Gnome3 F16?

asked 2011-11-20 06:26:52 -0500

FranciscoD_ gravatar image

Hello!

Since I've managed to customize my aterm as mentioned here: http://ask.fedoraproject.org/question/380/how-can-i-customize-aterm-on-fedora, I'd now like to change the default terminal to aterm. Currently, when I click the byobu icon, it opens up in gnome-terminal. I'd like to open it up in aterm. I've checked system-settings>system-info>default-applications, and there isn't an entry for default terminal there.

Thanks :)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-20 07:32:36 -0500

SoumyaC gravatar image

Can this help

gsettings set org.gnome.desktop.default-applications.terminal exec aterm

or if you have dconf-editor Go to (org->Gnome->Desktop->Applications->terminal) and change the value. Then reboot and check.

edit flag offensive delete link more

Comments

I tried this, still opens gnome-terminal. I used dconf to check, and yes, the value is now xterm, but it won't use xterm. Does one need to logout and in for changes to get implemented??

FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-20 07:50:46 -0500 )edit

try it, no harm : just a logout or reboot :)

SoumyaC gravatar imageSoumyaC ( 2011-11-20 08:00:56 -0500 )edit

did it work @FranciscoD_ ?

SoumyaC gravatar imageSoumyaC ( 2011-11-21 14:31:47 -0500 )edit
0

answered 2012-05-11 15:20:08 -0500

vxy gravatar image

Run gconf-editor and go to desktop->applications->terminal. Change the value of exec command to run aterm and you should be all set.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-20 06:26:52 -0500

Seen: 9,598 times

Last updated: May 11 '12