Ask Your Question

Brother network printer MFC-J5910DW doesn't print

asked 2016-04-02 05:03:30 +0000

jaaf64 gravatar image

I am using Fedora 23. I have installed all the brother files for the printer using the Brother utility available on their website. I also installed glibc.i686 which they indicate as a prerequisite. (drivers are 32 bit) After that I deleted the automatically installed printer that didn't work and installed a new one with cups at localhost:631. The installation seemed to be correct. I used lpd:// for the url as advised in the Brother Docs and marked the printer shared. Everything seemed to be OK but, when I print a test page or any page from any application, everything happens as if things were working fine (even receive the message "Impression términée" (Printing ended) and the cups admin shows the job as "completed at <date.time>") but there is no printing at all. I don't understand where the trouble comes from. I installed this printer (as well as an other model DCP-750CW) tens of times the same way on Ubuntu, OpenSuse, Gentoo, Mint and never met any trouble. I can ping the printer from desktop but l am unable to print. No error messages, print requests follow their way as if everything was ok but no printing happens.

edit retag flag offensive close merge delete


Anything in your syslog? or /var/log/* related to cups or lpd? Any SELinux denials?

genodeftest ( 2016-04-02 09:46:37 +0000 )edit

When I used a Brother printer on Fedora 23, I had trouble from SELinux. Fixed that. Then the printer worked. After some time, for no apparent reason, the printer ended up being being switched off in Gnome settings. So I just had to switch it back on to get it working again. Just my experience.

jtlinux ( 2016-04-03 05:13:02 +0000 )edit

1 answer

Sort by » oldest newest most voted

answered 2016-05-04 05:24:22 +0000

jaaf64 gravatar image

Eventually, I discovered that a small icon was appearing in the bottom-left corner of the screen. Clicking this icon made a windows open with the following title: " SeLinux Alert Eplorer" (this is translated from French). This widows told me I had to allow cups to execmen using :

$ su -c 'setsebool -P cups_execmem 1'

Then everything worked fine.

edit flag offensive delete link more


Thanks this one has been bugging me for years !

kenfallon ( 2017-07-20 12:48:11 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.


Asked: 2016-04-02 05:03:30 +0000

Seen: 159 times

Last updated: May 04 '16